Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Cisco AnyConnect VPN No Longer works on NOW

Today I've found that I can't connect to our work services using Cisco AnyConnect. I've rebooted my router several times and if I use a phone hotspot, my laptops are connecting fine. Anyone else struggling with this type of issue?

1 Reply

@Anonymous User 


Are you saying it worked before on Now, but has stopped?


If so, best go back and check if Broadband Buddy is still configured to let you use a VPN.


If not,  best go to Broadband Buddy and configure it to let you use a VPN.

Set a Payment PIN on your account so that no-one but you can buy memberships on it. Check your bank accounts monthly for any other unexpected payments to Now. That way you can at least nip them in the bud, while you and Now figure out whose fault they are.
If you take an offer that comes with a ‘free trial’ of Boost or another Membership, Cancel them straight away. You will still get the full duration of the trial, and if you decide you do want to continue with one or another of the trial products, just revisit the Cancel, and UnCancel it.