cancel
Showing results for 
Search instead for 
Did you mean: 

Activity in Content Issues / Missing Episodes

Pause Jumps

Everytime I leave NowTV paused for more than 10 seconds, upon pressing play the video will jump ahead approx 1 minute. Never reliably the same amount of time, and it causes buffering issues and time-outs when I try to click back to the correct timest...

Imogen by Newbie
  • 124 Views
  • 1 replies
  • 0 thanks

FBI Most Wanted S6 EP5 Missing

HiFBI Most Wanted S6 EP5 appears to be missing. Goes Ep4 then Ep6 Available Tuesday.Please can someone look into it?Thanks, UPDATE. I have just found the episode, looks like it's been added on its own and not part of the existing tile with all of the...

jropes12 by Newbie
  • 2416 Views
  • 17 replies
  • 11 thanks

Peacock nowhere to be found

Hi,I have the NOW app on my LG tv and all works well. I have all the passes. But I cannot fine Peacock anywhere! Not in my channels list. And there is no on demand section anywhere on the home page. I’m sure there used to be. it has new and trending,...

MissV by Advocate
  • 10771 Views
  • 7 replies
  • 6 thanks

Subtitles

I have just tried watching the well reviewed new series “The Diplomat”, but discover that there are no subtitles available, either on live TV or catchup on NOW, how can this be in today’s world?  Other series, including Person of Interest also do not...

NorthE by Advocate
  • 6477 Views
  • 12 replies
  • 2 thanks

No BBC i player on my Now stick

Hi,  I have had my Now stick a few years and yesterday BBCiplayer won't load. Everything else fine, also ok on my laptop. I have checked software updates as advised by the bot. Bit annoying it's gone, any idea why? I pay my licence fee etc.

Kay1 by Advocate
  • 256 Views
  • 3 replies
  • 1 thanks

Boost from Amazon does not work

I bought an Entertainment membership and Boost through Amazon on a Fire TV. Watching my favourite show and it's still plastered with ads. I've tried reinstalling the NOW app on the TV. Still ads. This morning I tried to watch with a browser on my PC....

Jazwax by Advocate
  • 239 Views
  • 1 replies
  • 1 thanks

Access Denied

I have been using the NOW tv player today and then it suddenly stopped working mid episode and came up with the error messageAccess deniedYou don't have permission to access on this serverI don't understand why it has suddenly stopped working as I wa...

Laura by Newbie
  • 5459 Views
  • 10 replies
  • 5 thanks
Labels