cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

Half the advertised Broadband Speed

Dear forum,

I have been a customer for about 6 months now, and the Internet speeds have always been working as advertised for my home. Always around the 40mbps. Which is fine. But last few days I can only receive 17mbps. The router testing page says its receiving 44mbps. Now Broadband technical page says the same and that there are no issues, however if I connect one laptop only for testing to the Router via Ethernet or Wifi 5G, I can only max out at that 17mbps. I have been using Fast.com and Speedtest.net, plus a few others out there and they all say the same... I cannot get more than 17mbps. I have tried on multiple devices and its the same story. My router setup has always had the wireless 2G and 5G separate, and the channels dont overlap my neighbours. Like I say its never been an issue since these last 2 days and nothing has changed on the router side of things. I dont understand how the Router can say its getting 44mbps when the laptops or phones or desktops via Ethernet or 5G wifi is getting a completely different speed. My final test was to download on one device multiple large .ISO files from all different websites, just to flood the connection and monitor the speed by TaskMGR, and yep it was still only able to hit the 17mbps 😞

Also using the online Now Broadband bot and trying to go through the online troubleshooting menus to be able to log this as an issue, just sends you round in a loop saying you have no issue, as it detects the router speed is fine. 

Any help on this topic is much appreciated πŸ™‚

 

4 Replies
gavs82008
Legend 5
Legend 5

@allankchambers 

There is a number to call which can easily be found with a quick search on the forum. Its likely to be a fault somewhere on your line. Ask for full investigation all the way back to the cabinet to be 100% certain.

https://help.nowtv.com/article/how-to-submit-a-broadband-complaint1

FYI that I do not work for NOW, just a NOW customer trying to help

Thank you Gav,

Calling them right now πŸ™‚

Support from the phone were also stumped as they could see from their end all looks good. It feels like either the router shows theoretical speeds, or the router itself can throttle outgoing connections via ethernet or wireless. I think the actual download speed from the Cabinet to my phone socket is currently at this low speed, which NOW Broadband perhaps cant detect from their end? Since I last posted I am now getting a constant 20mbps. So to me, that would mean, that maybe my neighborhoods ADSL lines could all be very busy? There is quite a few houses that share the same lines back to the BT Cabinet. But then I am thinking wouldn't NOW Broadband be able to pick that issue up? Its really an odd one. 

The guy I spoke to on the phone said he will check in again tomorrow to see if things have "auto magically" fixed its self.

Just to update the post, which may help others out that may have experienced my exact issue. I was able to resolve my issue by believe it or not... taking the power out of router and waiting for 30 mins before turning back on (before I was just power cycling it very quickly, no longer than 5 minutes). My theory was maybe the chipsets that control the ethernet and wifi could perhaps be too "hot". The router its self was I would say warm to the touch but nothing really to cry home about, normal heat in my view. Its on a table with nothing blocking its air flow, it has pride of place. Anyway I waited for it to cool down, and low and behold after waiting the 30 minutes where it was cold to the touch I turned it back on and straight away got the normal 40mbps. So maybe it was a temperature thing where the chipsets go into a throttle mode to save its own skin, or maybe it was just some random timings where the speed in my area was slow. My money is on the temperature throttling (if that is even a thing  for routers).