cancel
Showing results for 
Search instead for 
Did you mean: 
Clarice100
Advocate

Freesat on demand not working with NOW

Hello Community

 

We have a bizarre but extremely annoying issue… Ever since my mum switch to NOW TV she has not been able to use OnDemand services on Freesat.


NOW TV say that there is nothing wrong with the broadband… However, if I take her Freesat box to my house right next door and plug it into my BT router it works just fine. My own Freesat has no problems but if I take it into my moms house and connect to her NOW TV router we have the same problem of no on demand services.

 

I am being told that there must be a problem with the Freesat box, however as demonstrated it does work in another house and it does seem too much of a coincidence that this issue began the moment we switched provider to NOW TV. 

 

We have tried everything from factory reset to checking any security blocks on the line but nothing is working and there is not much point in buying a new box, as we have been advised today, as my new box does not work at her house either!

 

Has anybody else had this experience? 

13 Replies
schnapps
Legend 5
Legend 5

Hi @Clarice100 

 

I am assuming you are using Ethernet between the Freesat box and the NOW Hub 2 Router ?

 

This is a bit of a long shot, but have you gone into the Router webpage settings and changed the Ethernet setting from Gigabit to Fast Ethernet to see if this makes any difference.

schnapps
Legend 5
Legend 5

Clarice100
Advocate

Thank you. I’ve read the thread and I’ve tried everything suggested. Rebooted freesat box and router several times. Factory reset several times. 

freesat box tried connecting both by wifi and internet. 

freesat box says it’s connected. NOW TV say they can see the box is connected. Still no on demand. 

Has to be a NOW TV issue as the freesat box works fine with my BT router (NOW TV issue is my mum’s)

schnapps
Legend 5
Legend 5

Hi @Clarice100 

 

Also if the Freesat box has an option to run over wifi, then i would split the wifi bands on the NOW Hub 2 Router by following these instructions.

 

Your Hub Two is dual-band (2.4GHz and 5 GHz). Splitting these bands to create 2 different Wi-Fi networks can help to improve the speed to your devices. Here’s how to do it:

  1. Open your web browser and enter "192.168.0.1” in the address bar.
  2. Select Maintenance and enter “admin” and “nowtv” as the username and password.
  3. Select Wireless and then 2.4 GHz Wireless Settings
  4. Scroll down to “Wireless Access Point” and uncheck Synchronise 2.4GHz and 5GHz Settings.
  5. In the ‘Name (SSID)’ box, Change the network name to distinguish it from the current network (e.g. add “_2.4G” to the current name). Select Apply.
  6. Check the network name has been updated, and then select 5GHz Wireless Settings.
  7. To be able to see easily which network is which on your devices, change the ‘Name (SSID)’ here too (e.g. add “_5G” to the current name). Select Apply.
  8. That’s it. Select Logout at the top of the screen to exit.
Clarice100
Advocate

Thank you however NOW TV have already talked me through that and unfortunately it didn’t work

Clarice100
Advocate

oh gosh how do I do that? On the main account page? Will give it a go!

schnapps
Legend 5
Legend 5

Hi @Clarice100 

 

If the Freesat box is also wifi compatible, and splitting the 2.4ghz & 5ghz doesn't help, then try pressing in the WPS button on the front of the NOW Router until the light starts flashing to see if that makes any difference.

 

Hopefully a Freesat owner who had the same problem will assist you further.

 

 

Clarice100
Advocate

I don’t think my router has a WPS button! I couldn’t find one anyway…only power

Clarice100
Advocate

D’oh, found it!

schnapps
Legend 5
Legend 5

Hi @Clarice100 

 

I don't know if the WPS button will work, but make sure you are also on the Freesat relevant screen settings page, because it might ask you to connect to a Sky / NOW wireless network.

 

Can you get away with Ethernet on the Freesat box if you are going around in circles with wifi ?

 

Sorry i can't help any further, because i don't own a Freesat box (only a Youview box which works great with regards to the Apps over hard wired Ethernet on the NOW Hub 2 Router).

 

 

Anonymous User
Not applicable

That does sound like a very strange problem. When you say it doesn't work does it at least connect to the router? Go into the network settings on the freesat box and see if it is getting an I.P. address.

RoyB
Legend

@Clarice100 @Anonymous User @schnapps 

 

Just to clarify the issue a little, there is no actual such thing as’ Freesat on Demand’, but rather, what we are talking about is a Freesat device with internet catchup apps.

 

Which Now Broadband refuses to service, for some reason.

 

Though I doubt that this is because it is a Freesat device, particularly; there is something else here that Now doesn’t like.

 

So it would seem important to identify what make and model of Freesat device this is, which nobody has so far done.

 

(Of course, if this is happening on several different models of Freesat box, then I’ll get me coat).

=========================================================================
Please bear in mind that generally we are all customers like you, and so can’t help with billing or other queries that only Now can answer. We can try to point you in the right direction though.
Bb
Mentor

I am definitely not a technical person and I’ve got a similar problem .

I was with Now 2 years ago and everything was fine.

I’ve always had to use Ethernet cables as I appear to have a poor signal.

I watch tv and OnDemand through the freesat box and via a dish outside

I’ve switched to Now today and OnDemand tells me it’s loading then says should take one minute.  Been trying for hours and it’s still not coming on.

switched everything off and back on nothing 

I only want broadband to watch OnDemand and have a really bad feeling that my older tv and Freesat box are not compatible and 

Please help me if you can