cancel
Showing results for 
Search instead for 
Did you mean: 
Bb
Mentor

Freesat on demand not working with NOW Hub two

I am definitely not a technical person and I’ve got a similar problem .

I was with Now 2 years ago and everything was fine.

I’ve always had to use Ethernet cables as I appear to have a poor signal.

I watch tv and OnDemand through the freesat box and via a dish outside

I’ve switched to Now today and OnDemand tells me it’s loading then says should take one minute.  Been trying for hours and it’s still not coming on.

switched everything off and back on nothing 

I only want broadband to watch OnDemand and have a really bad feeling that my older tv and Freesat box are not compatible and 

Please help me if you can

0 Thanks
Reply
1 Solution

Accepted Solutions
Bb
Mentor

Re: Freesat on demand not working with NOW Hub two

Yay!
as if by magic checked at 8pm all loaded up.  Phew!

thanks again.

View solution in original post

6 Replies
schnapps
Legend 5
Legend 5

Re: Freesat on demand not working with NOW Hub two

Hi @Bb 

 

I don't own or ever used a FreeSat box, but what i would try first if using an Ethernet cable between the Sat box and your NOW Hub 2 Router is this below :-

 

After following the instructions below and if it still won't connect to your Sat box Apps, then maybe unplug the Ethernet cable at the NOW Router and try the second Ethernet port and also take out and plug back in the Ethernet cable at the Sat box end and then maybe unplug the power to both the Router and Sat box for a minute.

 

Then start the Router first say give it 5 minutes then power back up the Sat box and test out the Apps.

 

If that doesn't work go into the Sat box Settings to see if something needs changing under its Network / Internet Settings.

 

How to change from Gigabit Ethernet to Fast Ethernet

 

Go into the Hub Router web page settings by typing 192.168.0.1 in your internet browser url address bar and click on the Ethernet tab and when prompted use admin & nowtv for the username and password.

 

Then try changing from Gigabit Ethernet to Fast Ethernet and click on the green Apply button.

Bb
Mentor

Re: Freesat on demand not working with NOW Hub two

Many thanks for trying to help me.

I’m sorry, you can tell I’m not used to this.  I clicked the accept reply and it looks like it was a solution but I’m afraid not.

I’ve tried all the fixes you suggested and still have the same problem.

I know Now say that services could take up to midnight of the day they take over but I’m thinking it’s not going to happen.

It may be that I have to contact them directly.

Thank you again for trying.

0 Thanks
Reply
schnapps
Legend 5
Legend 5

Re: Freesat on demand not working with NOW Hub two

Hi @Bb 

 

is today your live Broadband & Phone activation date with NOW ?

 

if so ignore the above post of mine because i thought your internet is already live and working and you purely had a problem with your Sat Box only over Ethernet.

 

Leave the NOW Hub Router plugged in and powered up.

 

When you see the three green lights illuminated all the time on the front of the NOW Router, then you know the internet has gone live.

 

You may have to wait up until Midnight tonight if today is the live NOW Broadband & Phone activation date.

 

If no luck give the NOW Broadband Team a call tomorrow morning where they are open between 8am to 8pm using the telephone number from this link page below.

 

BTW - My internet went live around 7pm to 8pm when i joined NOW.

 

https://help.nowtv.com/article/how-to-submit-a-broadband-complaint1 

 

 

 

 

schnapps
Legend 5
Legend 5

Re: Freesat on demand not working with NOW Hub two

Hi @Bb 

 

Also to undo the accepted solution, you should be able to click on the Accepted Answer box again on my first post to remove the Accepted Solution.

Bb
Mentor

Re: Freesat on demand not working with NOW Hub two

Hi Schnapps

thanks for all your advice and patience!

 

Bb
Mentor

Re: Freesat on demand not working with NOW Hub two

Yay!
as if by magic checked at 8pm all loaded up.  Phew!

thanks again.