Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

New Apple TV 4k - "Sorry, Now TV is currently unavailable"

Just bought the new Apple TV 4k, in an attempt to be rid of the wretched Samsung TV apps. So far I've got as far as "Sorry, Now TV is currently unavailable", with a Retry button that does nothing.


I bought the Entertainment package too, but can't watch anything due to this. I refuse to use the Samsung TV app as it constantly crashes or flat out doesn't work. So far, I'm starting to think that it's just an issue with Now TV being a trainwreck.


The only other threads I found suggested removing PiHole, adblock, and something to do with a BT Smart hub. None of these apply to me as it's all on stock settings with a Virgin Hub 3.


What tops it all off is the fact that this very website has a chat button that does not work. Sky have blatantly added a fake chat button just to make you even more angry at the lack of support for their products. 


At this point it would be less frustrating to just buy an iPhone and stream shows from dodgy sites. This is about as calm as I'm capable of being given the ineptitude of the company.

Anonymous User
Not applicable
Anyone having the issue, I found from a tip from someone on twitter, uninstall the app and then reinstall today, and that has worked I am now able to use the App again.. I believe NowTV may have fixed the issue in the back end but it takes an uninstall and reinstall to allow the app to connect again..

View solution in original post

Legend 5
Legend 5

Hi @Anonymous User 


I don't know if there is still two versions of the NOW App on the ATV Apps Store (old version yellow & pink and new green & white coloured version designed for the ATV 4 and above generations boxes).


Where i am guessing you are using the new version ?


Can't help any further because i don't own a newer Apple TV box (only got the older ATV gen 3 box which i don't use anymore). 

Anonymous User
Not applicable



Yeah it's the newer app with the dark blue background and white text.


So far had to give the new rep my device serial number and model number so hoping this is a sign it'll be escalated and fixed!


Anonymous User
Not applicable

Well that was a massive waste of my time.


Over an hour with a chat agent just to be told "ummmm hurrrr must be Appuls fault derrrp".


Yeah sure, it's Apple's fault that the ATV 4k uses the same OS as the older ATV 4k that just happens to work fine.



Anonymous User
Not applicable

@schnapps The chat agent couldn't understand the difference between the ATV 4K 2nd Gen and the normal ATV 2nd Gen. He tried telling me my device was too old and no longer supported.


It's gonna be a long day.

Elite 3

@Anonymous User there's a very long running Apple thread that's quite active with users so try posting there.

@Anonymous User 

1. Seems to me as if the problem is that…


the NOW TV app for tvOS isn’t recognising the newly released tv 4K (2nd Generation) hardware as a valid device upon which said NOW TV app for tvOS is being run!


2. Seems to me as if the solution is that…


NOW TV need to do whatever is necessary to whitelist the newly released tv 4K (2nd Generation) hardware as a valid device upon which said NOW TV app for tvOS is allowed to be run!





Seems to me you are spot on.


Nothing else has changed but new physical hardware.  The app itself, for all its other faults, cannot be suddenly not working on the next generation TVOS box they release... otherwise ALL the existing apps would be incompatible and i doubt thats likely to happen.


A day early.. perhaps there's a problem but given everything else works then again the blame looks to be on Now


Also, very plausible that they have some hardware identifier that they need to enable in order to be sure their app is actually installed on the hardware it is intended for... so the blame seems to be firmly with them.


Sadly... Now have demonstrated that the AppleTV community... and the owners of their hardware are second class citizens and the fact that they omit something.. and dont admit to it, and dont fix it immediately on realising their mistake is par for the course.



My new AppleTV arrived today.... but i will keep an eye on this thread to see if Now have fixed their problem before I attempt to re-install the Now app.

Anonymous User
Not applicable

I too find that  NOW TV is unavailable on my new 4k Apple TV box which is very disappointing as the imminent removal of NOW TV from my previous generation Apple TV Box was the reason for update. I trust that NOW TV will compensate me for the loss of service.


Anonymous User
Not applicable

Piping in to say that mine isn't working either. Looks like it's all of us!

Well done Now, criminally unprepared as usual

Anonymous User
Not applicable

Mine isnt working either