Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

New Apple TV 4k - "Sorry, Now TV is currently unavailable"

Just bought the new Apple TV 4k, in an attempt to be rid of the wretched Samsung TV apps. So far I've got as far as "Sorry, Now TV is currently unavailable", with a Retry button that does nothing.


I bought the Entertainment package too, but can't watch anything due to this. I refuse to use the Samsung TV app as it constantly crashes or flat out doesn't work. So far, I'm starting to think that it's just an issue with Now TV being a trainwreck.


The only other threads I found suggested removing PiHole, adblock, and something to do with a BT Smart hub. None of these apply to me as it's all on stock settings with a Virgin Hub 3.


What tops it all off is the fact that this very website has a chat button that does not work. Sky have blatantly added a fake chat button just to make you even more angry at the lack of support for their products. 


At this point it would be less frustrating to just buy an iPhone and stream shows from dodgy sites. This is about as calm as I'm capable of being given the ineptitude of the company.

Anonymous User
Not applicable
Anyone having the issue, I found from a tip from someone on twitter, uninstall the app and then reinstall today, and that has worked I am now able to use the App again.. I believe NowTV may have fixed the issue in the back end but it takes an uninstall and reinstall to allow the app to connect again..

View solution in original post

Anonymous User
Not applicable

Try uninstalling the app and reinstalling this has worked for me this morning..