Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

AppleTV 4k new app fails to load

Hi there, 


I'd updated to the new NowTV app this week on AppleTV, and I had it up and running even watching a few football games on it. 


However a couple of days later I went to watch something and I got a message on the screen "Sorry, NowTV is currently unavailable". 


I tried deleting the app, re-downloading, logging back in. Still the same message. Briefly it displays "fetching your home page" or something similar before it shows the not available message. 


I thought it might be because I run my own DNS server on a PiHole on my local network, but even manually changing the AppleTV's DNS settings to the standard doesn't remedy the problem. 


I figure it's not my network either because the old TV app worked fine for years, and I can watch NowTV on multiple other devices in the house, iPads, PS5, xbox etc. 


Anyone seen similar issues? 

Legend 5
Legend 5

Hi @Anonymous User 


Anything in this link thread below helps ?