Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Updated Player (PC) now doesnt lauch - Java error?



I had this working previously, but then trying to launch the player today,. there was an advise of an update, so I updated it.


However now, when I try to launch the player, after a few moments the below error appears.

A JavaScript error occurred in the main process


Uncaught Exception:

Error %1 is not a valid Win32 application. 

(more text, too much to type up).



I've since uninstalled the player 4 times, including the deletion of all the related two folders in C:\users\username\AppData\Local for Now TV and Now TV Player.


I also uninstalled Java and reinstalled it, incase it was due to any out of date version.


Re-installing the player (latest version unknown as it doesnt launch and is not identified in the file name when downloaded (and restarting PC) has had no effect, and now I still cannot watch anything via the player. 


Not sure what else to try... 


This is on:

Processor AMD Ryzen 7 2700X Eight-Core Processor 3.70 GHz
Installed RAM 32.0 GB
System type 64-bit operating system, x64-based processor
Edition Windows 10 Pro
Version 20H2
OS build 19042.985
Experience Windows Feature Experience Pack 120.2212.2020.0

Any help would be appreciated.




Anonymous User
Not applicable

It since worked out, I can go into the shortcut of the icon for the programme, and set to launch as administrator.  This seems to now permit the application to launch properly but it will not let me open and stream programmes to it. 


So for example, I click on the "Lets go" button, this opens the browser to the programmes page, I then select the channel I want to watch from Google Chrome's browser,  it then askes me to launch the player, which I accept, but then shortly after, the same issue error comes up as explained in my first post.


Now that Ive been able to start the application, I can see its version 8.6.2 if this helps.


Anonymous User
Not applicable

Please see below screenshot of the Java Error if this helps.




Anonymous User
Not applicable

Have the same problem. Found Malwarebytes app was deleting/quarantining the tmp.node file shown in error message as malware. Turned off malware detection in Malwarebytes and the Now player opened no problem. 

Anonymous User
Not applicable



Thanks ever so much for taking the time to reply.


This indeed worked.  Its the .node file in C:\Users\######\AppData\Local\Temp


The problem is that you not should disable this sort of detection in this temp folder.


Hopefully there is a fix for this from either MWB or the NowTV player.


Trying to just add the node files as exceptions for each file doesnt work either, as it seems they are created continuously each time you launch the player and its a different filename each time.


So the only work around now, is to just temporarily disable the automatic quarantine option (or allow this temp folder to be excluded) until the player is launched then re-enable protection again. 


Thanks 🙂


Just had this error happen to me after updating to the latest player. MalwareBytes blocks the file in the tmp folder which prevents the player from launching when using google Chrome.


As a workaround I have turned of Automatic quarantining of files in Malwarebytes and used the Microsoft Edge browser to log in and choose the channel I wish to view, Malwarebytes blocks the file again but pops up a window allowing me to ignore the file. This allows the player to open and play the channel I selected. 

I have raised support ticket with MalwareBytes and will update this if I get an answer


As promised an update, I reached out to MalwareBytes and received excellent and very prompt advice on how to solve my issues.


The solution was simple for me, all I had to do was open Malwarebytes, open the settings tab and under the general tab scroll to the bottom of the window and click restore default settings, then restart the computer. After following these instructions the Now TV player loads properly from Chrome just like it used to.