Showing results for 
Search instead for 
Did you mean: 

Sky go app xbox


I’ve just switched to now Broadband & since moving I now cannot use the Sky go app on my Xbox. I’ve checked it’s not the Xbox or sky app issue by hotspotting my phone & it worked fine. I’ve also tried a mifi device which worked fine. 
My old provider was sky & also worked. It’s since the switch to Now.

ive disabled buddy & content related bars incase that had an effect but nothing. The usual, reset router, reset Xbox, deleted & re installed the app etc. but it’s not an app issue.

any fix please? 

Legend 5
Legend 5


Have you still got the Sky Router or did you have to return it back to Sky ?

If you still have the old Sky Router and it was a Sky SR203 or Q model like the NOW Hub then see if that works with the Sky Go App on the Xbox when using the NOW Broadband service (bearing in mind if you have NOW streaming Memberships you can't use the Sky Go services).

Also on the NOW Router are you using the Xbox over WiFi or Ethernet and does the other Apps on the Xbox run fine ?




I really appreciate your reply. 
For an unknown reason the sky go app on the Xbox started to work on the WiFi with no issues. 

Nothings changed. Perhaps an update which has happened? 
strange considering the app worked fine via hotspot & mifi device. 

Seems like it’s an issue with other users, but no fix to report. Just started working. 

if it helps diagnose for anyone else 

using WiFi, have tried Ethernet & didn’t work either. All other apps worked fine on the Xbox.