Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Hub Two and Network switches

I'm looking for help please.


I've recently tried to connect a network switch to my hub two.


Unfortunately I'm not getting any internet through the switch.


If I connect the same device directly to the router then it works, which lead me to believe it was either the cables or the switch.


I've tried different cables, and tried the switch at a friend's house where it worked perfectly (with another broadband provider).  I bought another switch by a different manufacturer but still have the same issue.


It's been suggested to me that I could have this issue of ports are blocked on the router, I've been into settings but cannot see this information.


Is this likely to be a cause or could there be compatibility issues?  Any help would be much appreciated.

Legend 5
Legend 5

@Anonymous User Shot in the dark here, but have all the cables you’ve tried been fully wired? A lot of cheap ethernet cables only have 4 wires (the minimum, older standard). It’s possible that the ethernet switch needs all 8 wires in the cable between it and the router, especially if you’re using the gigabit port on the router if it has one. 

Blocked, or open ports on the router have nothing to do with this issue as this is a purely hardware problem.



Anonymous User
Not applicable



The cables are cat6 gigabit ethernet cables.



Legend 5
Legend 5

@Anonymous User I did say it was a shot in the dark.


So, more questions:

1. When you connected to device directly to the router, did you use the same cable you use to connect the switch to the router?

2. When you tried the switch at you friend’s  house, whose cable did you use? If you used his, any chance you could borrow it to try in your set-up? If you used your friend’s cable at his house, try again using your cable.

3. Are you certain, and I’m sure you are, that the cat-6 cable is a standard patch cable? There are some differently wired cables out there.

The process of elimination is long, boring and often leads dented walls - the result of bashing one’s head against them.


One other thing, are you using the gigabit port on your router (if there is one)?


@Anonymous User 


@Mark_Weinreb touched on ‘differently wired cables’ of which the usual type is a crossover cable. 

Make sure you haven’t got any of these in the mix - it’s usually specified on a label or on the sheathing - and that all yours are straight-throughs.

Set a Payment PIN on your account so that no-one but you can buy memberships on it. Check your bank accounts monthly for any other unexpected payments to Now. That way you can at least nip them in the bud, while you and Now figure out whose fault they are.
Anonymous User
Not applicable



1. Yes same cable used.

2. I used my cables.


@RoyBand Mark

I'll recheck all cables.


Thank you both for your ideas and suggestions.

Legend 5
Legend 5

Hi @Anonymous User 


Are you referring to an Ethernet Hub switch with a number of outgoing Ethernet ports ?


If not then ignore the rest of my post.


 Should you be using an Ethernet Hub switch is it a managed or unmanaged switch ?


I use a Trendnet unmanaged 8 port Ethernet Hub switch on my NowTV Hub 2 and it was plug & play and works seamlessly for me on my NowTV Hub 2 Router.


If you are using an unmanaged switch have you tried pressing the reset button on the back of the Router for about 10 to 15 seconds ?


Should it be a managed switch then there would be some configuration involved on the Router (not sure what mind because my networking knowledge is limited).


Perhaps post the make and model of your Ethernet Hub switch on here ?