Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Can not log in

I have the now tv app on my roku express box. 4 devices were already added and have been the same devices for many months. Trying to use the app today it appears to have logged me out and won't let me log in saying.... Opps something went wrong we can not log you in right now. Please try again later. I have deleted all devices now and tried to re-log into all of them with no avail, also I've reset the roku and tried to delete and reinstall the app. Any clues please??

Legend 5
Legend 5

Hi @Anonymous User

Sounds to me that when signing into the NowTV App it thinks your IP address is not in the UK.

If you switch off the power to your router for 20 minutes, this should allow your router to automatically acquire a new IP address.

Then try and sign back into the NowTV App again.

If after you have signed into the  NowTV App and start playing some nowtv content on your pass and you see a message on screen saying something like "you have reached your maximum device limit".

Then contact live chat and ask them to reset all your devices on your account.

Link to live chat below.