Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Oops something went wrong. We're working on it

Hey everyone,

I bought the nowTV Smart box a week ago and it's been a nightmare since getting it out of the box.


Every time I try to watch live 'Sky' channels, e.g. Sky 1, it gives an error 'Oops something went wrong. We're working on it'. 

When I try to open the apps under 'Best of catch up', like iPlayer, they all give the same 'Oops something went wrong. We're working on it', including the 'NowTV' app. Although occasionally the apps will launch from that area. 

Pressing the 'NowTV' button on the remote will launch the app and I can stream box sets like 'American Dad' but I can't watch live Sky channels.


I've spent hours on different days with live chat going through various procedures of resetting the box, disabling network pings, changing my wifi network channel, doing forced software updates, resetting devices on their side of things etc.


Nothing has fixed the problem and all they can recommend is to take the box back to Argos. But Argos have refused to take it back and said unless it physically doesn't turn on, they're pretty much not interested. 


At this point I'm lost for ideas and thinking of opening a small claims court case. I know they probably won't turn up and would likely concede to a refund before letting it get to court.


Has anyone else experienced this? Ironically I bought this box with the idea of creating a video on my Youtube channel to explain how the NowTV box works and the reasons why you'd want it. But instead the video is going to turn into a rant about how glitchy the box is and how you're pretty much screwed if you buy it from a retailer instead of directly from NowTV.

Legend 5
Legend 5

Hi @Anonymous User,


What you are currently experiencing is certainly not normal. In order to help you, can you please provide the following information: -


  • What's your NOW TV playback devices 'software' version and NOW TV 'app' version?
  • How is your NOW TV playback device connected to the internet. Is it via a hard-wired or wireless (WiFi) ethernet connection?
  • Who is your ISP (Internet Service Provider)?
  • Are you running any form of VPN (Virtual Private Network)?
  • Have you tried re-booting your router (by disconnecting the power, waiting 30 seconds and reconnecting the power)?
  • Do other 'apps' such as BBC iPlayer work okay on your NOW TV playback device?

Sufficed to say, the more detailed information you are able to provide, the easier it will be for us NOW TV forum members and/or a NOW TV Team member to work out a solution for you!




Anonymous User
Not applicable

Thanks for the reply @SeeMoreDigital


1) NowTV Box 4500SK, Software Version 7.0, Build: 4215

2) Right now 2.4Ghz WiFi but I've also tested with ethernet and it gives the same result

3) BT ADSL, Homehub 4

4) No VPN

5) Yes I've tried rebooting the router and tried leaving it unplugged for minutes at a time.

6) iPlayer and other apps can be launched from the 'My apps' tab but not from the 'Best of catch up' tab. 




Anonymous User
Not applicable

Here's a few samples of what I see. As mentioned, launching the 'nowTV' app from 'Best of catch up' doesn't work but pressing the 'nowTV' button on the remote does launch the app succesfuly. 



Anonymous User
Not applicable

I've also just swapped the BT Homehub for a TP-Link router and the issue remains. I even did another factory reset on the nowTV box just to be sure.

Anonymous User
Not applicable


So I threw together a quick video about the problem, since my initial intention was to post a review video showing what a nowTV box is, how it works, the differences between the boxes and so on. 


I haven't yet made it public to my subscribers since I like to spread my videos out with a queue system. But it's viewable if you know the direct link.



Legend 5
Legend 5

@Anonymous User


Just wanted to say thanks for taking the time to put that video together and post it, I found it an interesting case to read about. I've not come across quite that combination of issues before (affecting all apps from the home screen, but on demand content from starting via remote button works whereas live doesn't) and in a way it's a shame you never got to the bottom of the issue as it would be interesting to know what it was.


Eye-opening to read about your experience with Argos, who seem to ignore the need for their goods to be 'fit for purpose' regardless of what exactly the issue was. I'm sure we've had mention of people returning boxes to Argos for various reasons on the forum in the past (voucher problems is a common reason) so it sounds like your particular branch was unusually unaccommodating.


Anyway, sorry you didn't get the help you needed on here or from Argos, and hope you got sorted with a refund in the end.