cancel
Showing results for 
Search instead for 
Did you mean: 
dribbler
Mentor

Account problem - Manage Devices is blank

When I select/click on 'Manage Devices' in my account, all I get is a busy icon and no list of devices.  I have left it 'indicating busy' for at least 10 minutes and the page remains empty.

 

Anyone have any ideas what's going on?

This post has been archived

This post has been kept only for reference, it may contain out-of-date or inaccurate infomation.

0 Thanks
1 Solution

Accepted Solutions
dribbler
Mentor

Re: Account problem - Manage Devices is blank

I am accessing my account via PC.  It is the correct NOW TV account for the 4 devices (1 LG TV and 3 NOWTV black boxes), that I am currently using.  I also keep getting 10021 concurrency errors even with 1 or no devices receiving a broadcast; this has been going on for a few days.

 

Never mind, I have just sussed the Manage Devives problem.  It's Firefox 50 causing the problem.  I tried Chrome and it displays correctly.

View solution in original post

This post has been archived

This post has been kept only for reference, it may contain out-of-date or inaccurate infomation.

2 Replies
SeeMoreDigital
Legend 5
Legend 5

Re: Account problem - Manage Devices is blank

Hi and welcome to the forum @dribbler,

 

  • What's the make and model number of the device you're using to access your NOW TV account?
  • Are you 100% sure that you've logged onto the same NOW TV account as your NOW TV playback device?

Sufficed to say, the more detailed information you are able to provide, the easier it will be for us NOW TV forum members and/or a NOW TV Team member to work out a solution for you!

 

 

Cheers

This post has been archived

This post has been kept only for reference, it may contain out-of-date or inaccurate infomation.

dribbler
Mentor

Re: Account problem - Manage Devices is blank

I am accessing my account via PC.  It is the correct NOW TV account for the 4 devices (1 LG TV and 3 NOWTV black boxes), that I am currently using.  I also keep getting 10021 concurrency errors even with 1 or no devices receiving a broadcast; this has been going on for a few days.

 

Never mind, I have just sussed the Manage Devives problem.  It's Firefox 50 causing the problem.  I tried Chrome and it displays correctly.

View solution in original post

This post has been archived

This post has been kept only for reference, it may contain out-of-date or inaccurate infomation.