cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Advocate

Help! For the Love of God!

Apologies for the typos I am dictating this due to my frustration.

Bought a NOW TV stick about  A week ago. I tried cancelling it after realising that I had the app on my Xbox one. That’s process proved fruitless and pointless. The people on the web chat were as useful as a floppy sock. In the end I accepted my fate and received the now TV stick. Are use a Hitachi smart TV  and the stick will not set up correctly. I can plug it into the mains no problem, I can plug the stick into the HDMI slot, no problem. I then proceeded to set it up and enter my Wi-Fi details, no problem. And then nothing. The screen goes blank and I proceed to having to restart the stick. I then get presented with a screen Asking me to pair my remote. I follow the instructions by pressing and holding the button on the remote for three seconds. The green button starts flashing. And then nothing. Nothing happens at all. The screen just remains. It says pair your remote. I asked the web chat people and they said that it appears to be working when obviously it isn’t because my screen is frozen it will not proceed. I even tried hardResetting the stick several more times only for it to insist that I pay my remote, which I do but then the screen doesn’t proceed. Eventually after 30 to 40 minutes of frustrating web chat with somebody who doesn’t understand what I’m saying he eventually agreed to send out a new stick. I set it up and input the Wi-Fi details on the new stick and then nothing. Repeat procedure. I reset the device and then it asked me to pair my remote I pair my remote and nothing happens. Is there something I’m doing wrong. There is nothing else I can do the screen literally freezes on the pair your remote screen. The remote is flashing green like it is as it should do but it will not respond when I press okay or anything. I am using a Hitachi TV it’s a smart TV but I don’t know what’s wrong with it please advise.

0 Thanks
Reply