Showing results for 
Search instead for 
Did you mean: 

Tenda AC1200 - No internet

I am using NOW broadband for over 2 years. The WIFI signal was not covering all the areas at home, so installed Tenda AC1200 to cover all the areas, it was working fine so far for both 2.4g and 5g. Somehow I have to move the Tenda from the place it was before. After connecting with wifi, the internet was not working, so I thought reset will help. I put all the information in static IP window but still show the same issue no internet.

Can someone help please?


I thought it could be because of cable, I changed it still the same issue. I tried all ports in the Now broadband device, also in Tenda.

No good luck 



Put the Now router back in place for the moment.

Does the internet now work?

If still not, contact Now Broadband and get it fixed. They wouldn’t look at the issue while you had a third party device connected.

If it does work with the Now router, you may need to contact Tenda to find out what’s going wrong with your Tenda device, or how it is set up.

Set a Payment PIN on your account so that no-one but you can buy memberships on it.
Check your bank accounts monthly for any other unexpected payments to Now.
That way you can at least nip them in the bud, while you and Now figure out whose fault they are.