cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

how to turn off dubbing on foreign programme?

I have been watching the italian series - Miracle.

The first 2 episodes were in italian with english subtitles

Then, overnight, the subtitles disappeared, and the programme was dubbed in bad American.

I cannot find a way to turn off the dubbing, and revert to Italian speaking with English subtitles.

Anyone help?

Labels (1)
5 Replies
GaryL
Expert 2

Re: how to turn off dubbing on foreign programme?


@Anonymous User wrote:

I have been watching the italian series - Miracle.

The first 2 episodes were in italian with english subtitles

Then, overnight, the subtitles disappeared, and the programme was dubbed in bad American.

I cannot find a way to turn off the dubbing, and revert to Italian speaking with English subtitles.

Anyone help?


There are both versions just select the version with the subtitles and that is in Italian.  On my roku it is in a second listing of season one.

Vanilla11
Newbie

Re: how to turn off dubbing on foreign programme?

Thanks for this. The American dubbing was horrendous!

0 Thanks
Reply
jonkino
Newbie

Re: how to turn off dubbing on foreign programme?

I only just discovered this series and it looks good but there is no subtitles and the American dubbed version is terrible - can't watch it. I go to subtitles and it says there are no subtitles available for this series. Any idea what is going on?

0 Thanks
Reply
jonkino
Newbie

Re: how to turn off dubbing on foreign programme?

Are you on NOW TV in UK? As far as I can see there is no Italian version of The Miracle. I want to watch it only in Italian with ENG subs but I can't seem to turn on subtitles and original language on - there is only this dreadful America English version on line on NOWTV.

0 Thanks
Reply
Caterina1
Newbie

Re: how to turn off dubbing on foreign programme?

Yes, this is absolutely ridiculous. Why would the option to watch in the original language be disabled. I am having the same problem. How frustrating.

0 Thanks
Reply