cancel
Showing results for 
Search instead for 
Did you mean: 
Geluk
Expert 2

Updated NowTV App on Win10 PC, but error message

As in subject line, when I run NOWTV app, and I/E 11 browser opens, I get the message attached.

1 Solution
Andy
Legend 5
Legend 5

@Geluk

 

The following is a workaround that works for me on a Mac, not sure if it works on Windows. 

 

1. Make sure you're logged out of the NOW TV website completely.

2. Go to http://www.nowtv.com/home/existing

3. Click on start watching for the pass you want to use. Sign in when prompted.

 

Now try watching and fingers crossed it will work.

 

I've reported the error to the team so hopefully it will be fixed soon.

NOW are looking for users to join their Customer Feedback Group and help improve the service. If you're interested read more here and sign up.

View solution in original post

14 Replies
m4ttgtr
Scholar

I just posted more or less the same. Both Win8.1 devices in a browser (any)

Andy
Legend 5
Legend 5

@Geluk

 

The following is a workaround that works for me on a Mac, not sure if it works on Windows. 

 

1. Make sure you're logged out of the NOW TV website completely.

2. Go to http://www.nowtv.com/home/existing

3. Click on start watching for the pass you want to use. Sign in when prompted.

 

Now try watching and fingers crossed it will work.

 

I've reported the error to the team so hopefully it will be fixed soon.

NOW are looking for users to join their Customer Feedback Group and help improve the service. If you're interested read more here and sign up.

Geluk
Expert 2

One step forward, one back

 

When I try to watch now see attached; no device changes made for many months,

and this WIN10 Laptop has long been a device.

Andy
Legend 5
Legend 5

@Geluk Hmm, can't help with that one but you probably know the drill by now ... Pop onto live chat, etc. Hopefully they'll sort out an extra swap when you explain.

 

I will send the team a message now tho to make sure they're aware of that as well.

NOW are looking for users to join their Customer Feedback Group and help improve the service. If you're interested read more here and sign up.

Andy
Legend 5
Legend 5

@Geluk The bug seems to be fixed now, if you still have the issue though post back and I'll mention it again. 

NOW are looking for users to join their Customer Feedback Group and help improve the service. If you're interested read more here and sign up.

Geluk
Expert 2

Being told to install Silverlight, which I already have; d/loaded again anyway, but won't work- see error message.

Silverlight.JPG

 

Using latest version of IE11 browser.

Turning off Active X filtering fixed that but produces this again re device limit:-

 

ie11.jpg

 

Tried EDGE but get "maximum number of devices" error 😞

 

Geluk
Expert 2

Following on from above I wonder if NOWTV can't cope with Windows 10 Updates

which may be changing device's signature?

Tony-D
NOW Team Member
NOW Team Member


@Geluk wrote:

Following on from above I wonder if NOWTV can't cope with Windows 10 Updates

which may be changing device's signature?


Believe it or not, even between Internet Explorer, Edge, and Windows 10 App counts as a device each. When you go to your device list does 'PC' pop up once or twice @Geluk? P.s i'm having serious issues with the Windows 10 App myself. Stuttering, crazy CPU and my PC has a 980Ti, 16GB of Ram and ian i5 6600k overclocked to 4.3Ghz.

 

 

Edit: I did get it working via IE 11, witha nice bitrate. I wonder why Silverlight isn't doing the job for you?

Geluk
Expert 2

Tks for reply; hadn't realised different browsers were counted as individual devices;

surely it should be looking at device id, not browsers.

Tony-D
NOW Team Member
NOW Team Member


@Geluk wrote:

Tks for reply; hadn't realised different browsers were counted as individual devices;

surely it should be looking at device id, not browsers.


Yeah yeah, before i joined NOW TV i had the device issue and had to get device changes through live chat. I didn't realise how bad the problem was on the Windows 10 App until yesterday and i've got it reported now for someone to look into it. @Geluk

Geluk
Expert 2

Thanks. 🙂

Geluk
Expert 2

Any progress on this?

 

I still have same issue despite deselecting my Dell laptop and re registering, as screenshot.

 

Anonymous User
Not applicable

Didn’t work for me 

Dan22341
Mentor

have you tried contacting support via the online chat