Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Laptop Now TV App - JavaScript Error in the Main Process

Have installed normally, installed as administrator, run as administrator, run in compatibility mode, restarted etc - the Now TV Windows App does not open for me, and I have just paid for a subscription.


Error as below - note, I have removed my real name and replaced with bolded capitilised username. Original text was a normal string of unbroken lowercase characters.


[Main Instruction]
A JavaScript error occurred in the main process

Uncaught Exception:
Error: Access is denied.
at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:172:20)
at Object.Module._extensions..node (module.js:598:18)
at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:186:18)
at Module.load (module.js:503:32)
at tryModuleLoad (module.js:466:12)
at Function.Module._load (module.js:458:3)
at Module.require (module.js:513:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (C:\Users\FAWBISH\AppData\Roaming\NOW TV\NOW TV Player\resources\app.asar\node_modules\@sky-uk-ott\client-lib-electron-keystore\src\encipher.js:3:18)
at Object.<anonymous> (C:\Users\FAWBISH\AppData\Roaming\NOW TV\NOW TV Player\resources\app.asar\node_modules\@sky-uk-ott\client-lib-electron-keystore\src\encipher.js:33:3)



I hope someone can assist, I'm missing the F1 currently and am out of pocket...


Have seen on some other threads that @Andy or  @Jason-C might be able to assist?




Anonymous User
Not applicable

@Anonymous User  I am facing the same issue. Did yours get resolved?

Anonymous User
Not applicable

I have this issue today over two years later.

It worked fine yesterday and after an update it doesn't work any more.

Sounds like they broke it again.

Why do Sky hate their customers so much.........

Anonymous User
Not applicable

I've got the same, after the update today.Screenshot 2021-11-17 150547.png

Anonymous User
Not applicable

I am having the same problem and judging by the remarks in here, no one is bothered to fix it, so I shall discontinue.

Anonymous User
Not applicable

Do you use Malwarebytes? I think the issue is that Malwarebytes is identifying files that the Now TV player creates as being malware.

Anonymous User
Not applicable

I have managed to resolve the issue by doing the following:

Settings > Add or remove a program

It should automatically be set to sort alphabetically

- Scroll down to NOWTV PLAYER

- Click on it and click uninstall

Go back to the NOWTV website and open up any movie or show's preview page

- Look for the small white text saying "Haven't downloaded the video player? Install Now"

- After going through the installation wizard, it ran as usual for me when I clicked "Start Watching"

(This worked for me but may not work for everyone)

(Also keep in mind I had the app downloaded from the website, which stopped working, I then re-downloaded it from the website. I haven't used the Microsoft Store version)

Anonymous User
Not applicable

Right, don't know if people are still having issues I think I may have fixed it.


It's a problem with admin rights. Running the NOW TV app 'link' as admin won't have any affect the .exe so you need to run the .exe as admin.


1. Close the player first and end any instances of the NOW TV app in Task Manager to be on the safe side.


2. Navigate to "C:\Users\*USERNAME*\AppData\Roaming\NOW TV\NOW TV Player" > Right click the NOW TV Player.exe > properties > Compatibility


3. Check the "Run as administrator" box


4. For good measure click the "Change settings for all users" and check the "Run as administrator" check box


5. Click OK


6. It should now stream


Allow full  access to the "NOW TV" folder in "C:\Users\*USERNAME*\AppData\Roaming"


1. Right click the NOW TV folder in "C:\Users\*USERNAME*\AppData\Roaming" > "Properties" from the drop down > uncheck "Read Only" > OK > let Windows do it's thang.


2. right click the NOW TV folder in "C:\Users\*USERNAME*\AppData\Roaming" > properties from the drop down > Security tab > Allow full control to admin and users as you wish > OK


3. Should now Stream


4. you and NOW are very welcome for fixing as issue, why NOW can't just post this, I don't know.