Showing results for 
Search instead for 
Did you mean: 

Loading content

I've just bought the sports membership and whenever I try and watch anything it comes up with an error message saying " unfortunately, we were unable to complete your purchase" , even though the payment has come through on my end and the membership shows as payed in the app.

Legend 5
Legend 5


What device are you using?

Have you tried unplugging your router for a few minutes?

What about trying another device?

Daft question, are you definitely signed in on the app? When you go to the settings cog, does it show your account that you paid for NOW with?
Some users don’t realise that they aren’t signed in and wanted to make sure just in case. 

FYI that I do not work for NOW, just a NOW customer trying to help
Legend 5
Legend 5

Hi @Elibiligili 

Is it happening on a PC by any chance or all your playback you have tried? 

If it's happening only on the PC, then a few people reported this and to fix it they did a resync on their PC clock.

Also type in the NOW Community search box the error message for other related results.


Legend 5
Legend 5

Hi @Elibiligili 

Should the message only occur when watching on a PC, this is what another forum did to clear the message on their end,

If it is all your playback devices encountering the message, then ignore the instructions below and it could be a number of other things that needs looking into.

See instructions below :-


Upon rebooting my laptop I found that the issue returned. I noticed that my system clock was one hour behind despite having it set correctly. As I'm on Windows 11, I was able to go to:

  • Settings
  • Time and Language
  • Date and Time
  • Ensure that my timezone was set correctly
  • Then click 'Sync Now'

I was then able to log into my account and start watching TV again.