cancel
Showing results for 
Search instead for 
Did you mean: 
JohnMcD
Advocate

Chromecast

Ever since I swapped my broadband from EE to Now I've struggled to get my Chromecast working properly. I've got a Chromecast TV dongle, two audio dongles, three nest speakers and and LG speaker with Chromecast built in. Three of the devices work sometimes and the rest won't connect at all. Any ideas what might be going on?

0 Thanks
Reply
1 Solution

Accepted Solutions
schnapps
Legend 5
Legend 5

Re: Chromecast

Hi @JohnMcD

 

I run three Chromecast dongles on the NOW Hub Router 2 with no problems.

 

Have you split the two WiFi bands on the NOW Router and select 2.4 ghz which works fine on my Chromecasts. 

 

Plus make sure your casting devices are on the same WiFi network has the Chromecast dongles

 

Here's the instructions if you haven't done it already.

 

Your Hub Two is dual-band (2.4GHz and 5 GHz). Splitting these bands to create 2 different Wi-Fi networks can help to improve the speed to your devices. Here’s how to do it.

  1. Open your web browser and enter "192.168.0.1” in the address bar.
  2. Select Maintenance and enter “admin” and “nowtv” as the username and password.
  3. Select Wireless and then 2.4 GHz Wireless Settings
  4. Scroll down to “Wireless Access Point” and uncheck Synchronise 2.4GHz and 5GHz Settings.
  5. In the ‘Name (SSID)’ box, Change the network name to distinguish it from the current network (e.g. add “_2.4G” to the current name). Select Apply.
  6. Check the network name has been updated, and then select 5GHz Wireless Settings.
  7. To be able to see easily which network is which on your devices, change the ‘Name (SSID)’ here too (e.g. add “_5G” to the current name). Select Apply.
  8. That’s it. Select Logout at the top of the screen to exit.

 

 

View solution in original post

0 Thanks
Reply
3 Replies
schnapps
Legend 5
Legend 5

Re: Chromecast

Hi @JohnMcD

 

I run three Chromecast dongles on the NOW Hub Router 2 with no problems.

 

Have you split the two WiFi bands on the NOW Router and select 2.4 ghz which works fine on my Chromecasts. 

 

Plus make sure your casting devices are on the same WiFi network has the Chromecast dongles

 

Here's the instructions if you haven't done it already.

 

Your Hub Two is dual-band (2.4GHz and 5 GHz). Splitting these bands to create 2 different Wi-Fi networks can help to improve the speed to your devices. Here’s how to do it.

  1. Open your web browser and enter "192.168.0.1” in the address bar.
  2. Select Maintenance and enter “admin” and “nowtv” as the username and password.
  3. Select Wireless and then 2.4 GHz Wireless Settings
  4. Scroll down to “Wireless Access Point” and uncheck Synchronise 2.4GHz and 5GHz Settings.
  5. In the ‘Name (SSID)’ box, Change the network name to distinguish it from the current network (e.g. add “_2.4G” to the current name). Select Apply.
  6. Check the network name has been updated, and then select 5GHz Wireless Settings.
  7. To be able to see easily which network is which on your devices, change the ‘Name (SSID)’ here too (e.g. add “_5G” to the current name). Select Apply.
  8. That’s it. Select Logout at the top of the screen to exit.

 

 

View solution in original post

0 Thanks
Reply
schnapps
Legend 5
Legend 5

Re: Chromecast

Hi @JohnMcD

 

With the devices that currently won't play ball with the Hub Router, perhaps factory reset them after you have split the two WiFi bands on the NOW Hub Router and start from scratch again. 

0 Thanks
Reply
JohnMcD
Advocate

Re: Chromecast

Hi Schnapps thanks for an excellent solution. Cheers John