cancel
Showing results for 
Search instead for 
Did you mean: 
NeilHW
Newbie

Fire stick Now App

I use Now TV on a Firestick.

 

Subtitles have suddenly started appearing on every live broadcast. There appears to be no way of accessing any settings. I have no idea why this has started happening.

 

im used to turning subtitles on and off during replays of films etc, the menu button and the speech bubble. 

The menu button on my fire remote does nothing during live broadcast. The back button from ‘home’ takes you out, not to a menu.

 

TV subtitles are ‘off’

 

short of deleting data on the app and reinstalling I have no more ideas


there is no settings menu at the bottom of the screen

 

any advice appreciated

 

Labels (1)
0 Thanks
Reply
9 Replies
schnapps
Legend 5
Legend 5

Re: Fire stick Now App

Hi @NeilHW 

 

When watching a NOW live feed, press the enter button on the Amazon Fire Stick Remote and the NOW and Next TV Guide information bar of the live channel you are on should pop up on your television screen.

 

If you then navigate far right and click on the bubble speech icon it should then give you the option to either disable or enable subtitles.

 

Should it keep occurring, then you may have to go into the Fire Stick Settings and disable (subtitles /closed captions assuming this feature is on the Fire Stick which i haven't checked).

0 Thanks
Reply
NeilHW
Newbie

Re: Fire stick Now App

Hi ,
Thank you for your reply - 
"If you then navigate far right and click on the bubble speech icon it should then give you the option to either disable or enable subtitles"
that doesn't happen. There is nothing on the far right to navigate too after the program info bar comes up, let alone a speech bubble. Tried that last night and again just now for sanity check.

Thank you anyway
0 Thanks
Reply
schnapps
Legend 5
Legend 5

Re: Fire stick Now App

Hi @NeilHW 

 

I assumed the NOW App on the Fire Stick had the live subtitles update has my Roku and NOW players hence the instructions.

 

I have just fired up my Amazon Fire Stick and like you said i can't seem to find an option on the live channels with regards to the bubble speech icon.

 

Though i am not seeing any subtitles on my Fire Stick NOW App live broadcasts.

 

I am guessing you have tried going back into on Demand stuff on NOW and make sure subtitles is switched off if you have already disabled closed captions / subtitles in your Fire Stick Settings.

 

Only other thing is to try a fresh NOW App.

 

Maybe report it to NOW live chat.

0 Thanks
Reply
NeilHW
Newbie

Re: Fire stick Now App

I never anticipated that the settings on the stick had changed as it was only Now that seemed to be affected. The subtitle setting in the firestick had been switched to 'on'. There is only me in the house and I didn't do it.
It's now resolved. Thank you for helping me 'think'.
taNeil
Sallysimp
Advocate

Re: Fire stick Now App

Please can somebody let me know how to turn the subtitles off please.

using now Tv app on a fire stick. No options to do this anywhere

 

gavs82008
Legend 5
Legend 5

Re: Fire stick Now App

@Sallysimp 

Have a nosy at this link.

https://www.amazon.co.uk/gp/help/customer/display.html?nodeId=201493150

FYI that I do not work for NOW, just a NOW customer trying to help
Mistertm
Advocate

Re: Fire stick Now App

Hi

this appear to only apply to Amazon prime videos but not the nowtv app.

thanks 

0 Thanks
Reply
RoyB
Legend

Re: Fire stick Now App

@Mistertm 

 

I believe that the Now app on the Firestick feeds off the global Firestick setting, and does not have its own local setting for subtitles. 

 

Have you actually tried it, see if indeed that’s the way it works?

 

On other devices, though, you can pause the program, go to the little speech bubble thus revealed, and set subtitles on that way.

 

Maybe try that if the above does not work.

Line 3. Overhead, without any fuss, the stars were going out…..
Mistertm
Advocate

Re: Fire stick Now App

Hi

There appears to be a subtitle setting under the accessibility menu. I’ve turned all the options off and this appears to have worked.

Thanks for the pointers.