Showing results for 
Search instead for 
Did you mean: 

No internet despite set up today


Recently got my brilliant broadband (ironic) Now TV hub 2 router installed by engineer today. For first 20 minutes worked fine and had internet connection but upon leaving the flat and coming back we noticed it had no connection at all to the internet. Yet displayed wireless and power as still functional. I’ve tried rebooting, resetting, re-wiring. Can’t seem to find the issue, currently using a master micro filter however that seems fine as well, I’ve tired following the reboot process using a Ethernet but no luck either.


Considering Now already messed me around by delaying the set up by over 2 weeks, not happy at all with how little effort everything seems to done on their end. 

My connection date was listed as today, any help is appreciated. 

Champion 2

Have you checked that your landline is working as it should? Subject to that you will need to contact NOW directly as they do not provide support via the community, click here