cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

No internet connection error 009

Hi

I am trying to setup a smart stick.  I have Now Broadband that gives out IP addresses via wi-fi and also my own router that has been set up to act as an access point.

I can connect the stick to both routers no problem but the stick will not access the internet through either device.  I have tried two different televisions just in case it was that (not that I can see how it would be).

I managed to find a secret menu where I could see some information.  It looks like no matter which router it connect through, the IP address it shows is not one that my router gives out.  My range is 192.168.0.x but the smart stick has IP address 10.0.0.x.

I can see that there is a manual IP configuration but there is no way to change this, only look at it.

As I work in IT I am pretty competent at configuring devices and in cases like this, I would use the static IP option.

Does anyone know how to change the static IP address or does anyone know what would cause the stick to have the wrong IP address?

1 Solution
schnapps
Legend 5
Legend 5

Hi @Anonymous User 

 

Bit of a long shot have you tried to use your smartphone has a wifi hotspot with the stick.

 

If the stick connects over wifi over your phone, then let it carry out any software updates.

 

Then once the stick has been setup and activated on your account, swap it back onto your router home network wifi.

 

Worth a try.

View solution in original post

6 Replies
schnapps
Legend 5
Legend 5

Hi @Anonymous User 

 

Bit of a long shot have you tried to use your smartphone has a wifi hotspot with the stick.

 

If the stick connects over wifi over your phone, then let it carry out any software updates.

 

Then once the stick has been setup and activated on your account, swap it back onto your router home network wifi.

 

Worth a try.

Anonymous User
Not applicable

Hi

 

That has sorted it, many thanks

Anon1
Advocate

Worked thank you!

Anonymous User
Not applicable

New stick, thanks to NowTv no longer supporting white boxes (I did have problems connecting way back when I got white box, but got them sorted)

Can connect to WiFi, but no internet, error 009

My Set up:

Virgin super hub 2

Mac address of stick added

 

What I've tried, not necessarily in this order!

Connecting via mobile hotspot and updating software. All done

Restarted router

Disabled pings (as suggested in a number of posts)

enabled said pings when disabling didn't work

Set up guest WiFi on hub - still no internet connection

Turned firewall off on router.

Did full reset on stick and started the process again!!

Nothing will get rid of that wretched red x

 

Whilst I don't work in IT, I'm pretty good at solving issues with my set up, but I've spent all evening trying to get this thing working!

 

Help!!

 

 

Anonymous User
Not applicable

Looks like I've sorted it, went into hub settings, one by one, Mac filtering, the stick had a tick in an "enable" box, where no other of my kit had said tick, unticked, applied, and as if by magic stick connected! Could've saved whole load of angst last night if I'd spotted the anomalie! 

smithbill17
Mentor

I'm having this problem but can't resolve it. I have a DHCP server (192.168.8.x) on my LAN which is *not* the router. I also have a Wireless Access Point on a separate subnet (192.168.1.x).

 

I connect my NowTV stick to the WiFi and it gets a 192.168.8.x IP address. However, if I go to the secret network menu and view the static IP configuration, it shows an IP of 192.168.1.x with Gateway 192.168.1.1 and no DNS servers.

 

I suspect the wrong Gateway & no DNS servers is the reason I keep getting the "Sorry, can't connect right now" issue.

 

There is no way to configure the NowTV with a static IP. I've added it's MAC address to my DHCP server, but that makes no difference.

 

Anyone any ideas how to correct the static IP details (Gateway & DNS servers) on the NowTV stick?

 

I am on the latest 9.3.3.4104 firmware.