cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Advocate

New iPad Pro and now tv app not working

I have a new 12.9 iPad Pro. The iOS is the latest version, the Now TV app is the latest version. I logged into my account online and removed my old iPad from the list of linked devices, so when I logged in with my new iPad, I was able to log in with an available slot. But no matter what I do, I get an error message saying;

'Something's not right. Give it a moment, or check nowt.com/status for updates (0)'.

 

I have my account set up on two NOW TV boxes and also on an LG TV, all set up with the same account name and password. It is working, without issue, on those devices. However it will not work on the iPad (it did work on the old iPad). I keep getting the same error message.

 

I have logged out and logged back in, I have even logged out, soft reset my iPad (holding down both home and on/off button until the apple logo appears) then logging in, but nothing. I have also deleted the app and reinstalled it, but the same error message keeps coming up.

 

I can't see any issues on the Now TV status that I found. Any ideas as to the issue and a fix? Thanks in advance. 

 

This post has been archived

This post has been kept only for reference, it may contain out-of-date or inaccurate infomation.

0 Thanks
1 Reply
Highlighted
Advocate

Re: New iPad Pro and now tv app not working

Missed a discussion of lots of people having the same error message, further into these pages... seems a fix is unknown at the moment. 

This post has been archived

This post has been kept only for reference, it may contain out-of-date or inaccurate infomation.

0 Thanks