Showing results for 
Search instead for 
Did you mean: 

Activity in Entertainment

Wall-e movie

Hello,The movie Wall-e is out of center of the screen. can somebody fix this, please Thank you 

Watching HD films

I've just rented Secret Life of Pets 2 for my grandson.  My son is having problems playing the film. When I've tried to find what might be the problem I can see after the film's title it has the HD symbol. If my son's TV is not HD compatible does tha...


Is there any way to see the upcoming schedule of movies and shows. For example I can't find any information on Get Shorty Season 3. Do Now TV just not bother telling anyone what is coming.

Den61 by Advocate
  • 2 replies
  • 1 thanks

problem streaming film via lg tv

Hi just wandering if any one can help me please,  basically i have a now tv cinema pass and my little one wants to watch the good dragon it’s a film on sky cinema but it won’t work on my lg tv it says “unable to complete purchase on this device” but ...

Resolved! Movies 24 / Christmas 24

Hey, Does anyone know if NOW TV does the channel Movies 24? I'm sure that is the channel that changes to Christmas 24 near Christmas time.  Thanks 

Apple TV 4 app

The now tv app on my Apple TV 4 is not updating with the recently added movies so latest is aquaman from 2 weeks ago. I have tried resetting Apple TV and deleting reinstalling app but no change any help would be great thanks

Titles are currently unavailable

There are no titles under movies even though I have a pass. It says “these titles are currently unavailable” Anyone know how to get them back. I can’t find anything to suggest it’s a planned outage 


Hello all. Could someone please help. I was removing old devices from my now tv app and I’ve removed my current devices by mistake and now can’t use now tv til next month! Can someone please help. Thank you

Resolved! Ready Player One Missing

I am trying to watch Ready Player one but for some reason, the sound is missing. Like, the advert before will have sound, any other film will have sound when I put it on but RPO has no sound whatsoever. Just on my NowTV box though. It's working fine ...