cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

poor range of wifi

Hi,  Ive recently had my NOW router/modem installed in a new flat, but when I go upstairs I cannot get any wifi at all. Its a small 2 bed and this really should not be happening when im barely 10m away - any ideas please?

2 Replies
Anonymous User
Not applicable

I’ve got the same issue, it’s a 3 bed terraced house and we get WiFi in the front room, dining room and then upstairs bedroom directly above the living room. 

everywhere else in the house it doesn’t work which is really really poor. 

How do you log a complaint instead of coming to this community hub. 

gavs82008
Legend 5
Legend 5

@Anonymous User @Anonymous User 

If you split the Wi-fi signal to 2.4ghz and 5ghz, this should improve the speed and range. 

 

https://help.nowtv.com/article/improve-broadband-speed

Your Hub Two is dual-band (2.4GHz and 5 GHz). Splitting these bands to create 2 different Wi-Fi networks can help to improve the speed to your devices. Here’s how to do it:

  1. Connect your Hub Two to your laptop or computer using an Ethernet cable.
  2. Open your web browser and enter "192.168.0.1” in the address bar.
  3. Select Maintenance and enter “admin” and “nowtv” as the username and password.
  4. Select Wireless and then 2.4 GHz Wireless Settings
  5. Scroll down to “Wireless Access Point” and uncheck Synchronise 2.4GHz and 5GHz Settings.
  6. In the ‘Name (SSID)’ box, Change the network name to distinguish it from the current network (e.g. add “_2.4G” to the current name). Select Apply.
  7. Check the network name has been updated, and then select 5GHz Wireless Settings.
  8. To be able to see easily which network is which on your devices, change the ‘Name (SSID)’ here too (e.g. add “_5G” to the current name). Select Apply.
  9. That’s it. Select Logout at the top of the screen to exit.
FYI that I do not work for NOW, just a NOW customer trying to help