Showing results for 
Search instead for 
Did you mean: 

err_address_unreachable issue

I keep getting the error message "err_address_unreachable" on certain websites. 

It happens across multiple devices (laptops, pc, phones) using different browsers. I have cleared caches, disabled firewalls/anti virus and flushed/changed my dnd settings. I've reset the router multiple times. 

Whenever I tether my phone data to a computer, or turn the wifi off on my mobile. The websites load with no issues so it's definitely something to do with my now tv router or connection. 

I am unable to log into as that also shows as "err_address_unreachable". Extremely frustrating, any ideas?


Edit: iPhone has 0 issues, only affects Windows and Android devices 

Legend 5
Legend 5

Hi @Rh47 

You could have a mess around with your Broadband Buddy Settings on your online NOW account, but reading this linked thread below taken from the Sky Community forum it looks like the Sky Shield (Broadband Buddy equivalent) didn't make any difference.

The linked thread below had something similar to what your experiencing and unplugging the power to the Sky Router for 30 minutes to acquire a new Router IP worked for somebody and using the Google DNS on their internet connected devices worked for another person.

Might be worth a go if you haven't done this above already. 

Edit - Maybe also try a hard reset on the NOW Router by holding in the reset button on the back of the NOW Router for around 15 seconds before trying the above suggestions on the link.

Elite 3

If you're unable to log into the router, I would concentrate on curing that, because once you can I'm sure all the other problem will go away.

I would factory reset the router, and just connect with one device, preferably wired, and if you can then connect to the router, try adding other devices one at a time.