cancel
Showing results for 
Search instead for 
Did you mean: 
huntersmob
Advocate

broadband hub

i need help with more ports on the rear of the  router. the 2 it comes with is very poor.

 

i have my old router( now configured to work this way) into the  back of the [voucher code removed] one  but one of the devices it struggling to connect this way ( it keeps going  offline  and i need to switch it off and power up again

 

any suggestions

 

5 Replies
schnapps
Legend 5
Legend 5

Hi @huntersmob 

 

I am guessing you have tried plugging in the problem device straight into the spare second Ethernet port on your NOW Hub Router than using the old Router and vice versa ?

 

What's the Ethernet spec on the device given you a problem does it only have a 100Mbps Ethernet port on it ?

 

There is a setting in the NOW Hub 2 Router to change from Gigabit to Fast Ethernet, but it will affect both Ethernet ports if you make the adjustment.

 

When i joined NOW Broadband i decided to buy an unmanaged 8 port Ethernet Hub from Amazon for around £10 (a few years back) rather than using my old Router has an Ethernet hub for the additional required Ethernet ports needed in my setup.

 

huntersmob
Advocate

I be seen one of these

TP-Link TL-SF1008D 8-Port 10/100 Mbps Desktop Ethernet Switch/Hub, Ethernet Splitter, Plug & Play, no configuration required
https://www.amazon.co.uk/dp/B0041JM6GM/ref=cm_sw_r_awdo_navT_a_Q0HB0GDB1VV4RTWEAE80?psc=1

schnapps
Legend 5
Legend 5

Hi @huntersmob 

 

I am using a Trendnet 10/100/1000 Mbps Gigabit unmanaged 8 port Ethernet Hub.

 

Thinking back i actual purchased it about 5 or 6 years ago when i had my BT Hub Router but still needed extra Ethernet ports on the four ports on the BT Router.

 

My Ethernet Hub was plug and play when i used BT and when i also switched to NOW using their Hub 2 Router.

 

if it was me i would pay a little extra and go for a 10/100/1000 Mbps Gigabit Ethernet Hub and not a 10/100 Mbps Ethernet Hub.

huntersmob
Advocate

Cheers I will order the better one

schnapps
Legend 5
Legend 5

Hi @huntersmob 

 

I just hope the problematic device you have will work (though no guarantee and you may have to investigate the reason why in more detail).

 

All my internet connected devices that i own that are plugged in over Ethernet to my 8 port unmanaged Ethernet Hub have been running fine from day one when i switched to NOW Broadband (nearly four years ago) and for me it was simply plug & play.