Showing results for 
Search instead for 
Did you mean: 

Well, that didn't go to plan

I've just joined NOW TV Broadband a few days ago, and I'm now trying to manage my account. So far I tried to look at my payments, manage parental controls and modify Broadband Buddy.


Everything I try simply generates the message "Well, that didn't go to plan. Please wait a moment and try again."


I've waited many moments - hours, in fact - and tried using Firefox, Edge and Chrome. Nothing works, just get the same error message.


Any suggestions?

4 Replies
Expert 3

Give it a week or so, mine took about a week before the oops message went away


It's now been 10 days and no improvement. How long have other people had to wait before the account works properly?


omg same, ive had broadband buddy for months now and keep encountering the same red sign with an exclamation mark. ive tried looking online and asking on here but i cant seem to find a fix. i hope someone responds soon with a solution

Legend 5
Legend 5


Only customers like you and me will reply to posts relating to broadband issues. 
Have replied to the thread you started.

FYI that I do not work for NOW, just a NOW customer trying to help