cancel
Showing results for 
Search instead for 
Did you mean: 
James
Advocate

Trouble with DEVOLO Powerline Adapters

I have DEVOLO powerline adapters fitted in my home that provide Wi-Fi instead of my NOW TV router. The logic being that all my home devices (nearly 40 now) are connected to the DEVOLOs, instead of the router, making it easy to switch internet service provider to take advantage of offers etc..

The DEVOLO devices were dLAN® 1200+WiFi ac types.

I encountered an issue where all my DEVOLO devices suddenly stopped providing internet through Wi-Fi at the same time. The same Wi-Fi SSID was being broadcast and would allow connection - but there was no internet provision. Unable to fathom the issue using the DEVOLO web interface I decided to factory reset the devices and start the set up again using a configuration backup I had taken.

Rather bizarrely I found that the DEVOLOs were not accepting any changes to their IP addresses to the same IPv4 subnetwork (i.e. 192.168.1.XXX), instead a different IP address would persist (i.e. 169.254.10.146), despite repeated configuration attempts.

In the end I decided to buy new DEVOLO Powerline adapters as I could not resolve the issue. This time I purchased the latest WiFi 6 devices from the MAGIC2 range. When these setting up I encountered the exact same issue (unable to set an IP address in the same IPv4 subnetwork) which informed me that the issue was not with the DEVOLO devices but elsewhere in the network.

After playing around with the configuration of my NOW TV Hub Two router I eventually resolved the matter by disabling the energy efficiency setting. Once this feature had been disabled my DEVOLOs would accept an IP address change and everything started working perfectly.

To disable this setting:

LOG IN to the router (usually 192.168.1.1) > Go to the ETHERNET tab > at the 'Energy Efficient Ethernet' option select DISABLED from the drop down > hit the APPLY button.

For information, EEE reduces power consumption during periods of low data activity by up to 50%.

I could not find a solution to my DEVOLO problem elsewhere so I thought I would post this to help others with the same problem.

6 Replies
Jayach
Elite

169.254.10.146 is an auto generated I.P. address, it means the device couldn't find a DHCP server.

Why the energy efficiency setting would cause that I have no idea.

But yes, it may well help others with the same problem.

RoyB
Legend

@Jayach @James 

Presumably the Now router has its WiFi disabled, but is still acting as the DHCP server, for the DEVOLO connected to the router by wired Ethernet, and all the devices using WiFi via it?

Maybe EEE, to save power, stops or restricts the DHCP service so the router does not ‘see’ the DEVOLO requesting the new IP address?

Just a WAG…..

Set a Payment PIN on your account so that no-one but you can buy memberships on it. Check your bank accounts monthly for any other unexpected payments to Now. That way you can at least nip them in the bud, while you and Now figure out whose fault they are.
Jayach
Elite

It's difficult to know what a router could do to make itself more "energy efficient" and still do it's job. Turn the LEDs off is the only thing I can think of.

James
Advocate

This is the Wiki text on how EEE works:

The power reduction is accomplished in a few ways. In Fast Ethernet and faster links, constant and significant energy is used by the physical layer as transmitters are active regardless of whether data is being sent. If they could be put into sleep mode when no data is being sent, that energy could be saved. When the controlling software or firmware decides that no data needs to be sent, it can issue a low-power idle (LPI) request to the Ethernet controller physical layer PHY. The PHY will then send LPI symbols for a specified time onto the link, and then disable its transmitter. Refresh signals are sent periodically to maintain link signaling integrity. When there is data to transmit, a normal IDLE signal is sent for a predetermined period of time. The data link is considered to be always operational, as the receive signal circuit remains active even when the transmit path is in sleep mode.

James
Advocate

Yes all your assumptions are correct.

But note that the DEVOLOs now work whether the NOW TV Wi-Fi is active or not, but I have disabled the NOW TV Wi-Fi to force every device to connect through the permanent DEVOLO Wi-Fi.

James
Advocate

I should add that Energy Efficient Ethernet is disabled by NOW TV when the router is shipped, I had enabled this setting in ignorance when I switched ISP two months ago. I don't know why my DEVOLOs worked for the fist two months and then stopped working now - possibly a firmware update was rolled out?? (my firmware version is 4.32.0403.R).