cancel
Showing results for 
Search instead for 
Did you mean: 
agt
Advocate

Streaming performance issues

Sorry if this is already covered elsewhere - I've no idea what key words to use to find the answer if it already exists.

Setup:

I am using a TCL Roku TV. The NOW TV Hub Two is broadcasting both the 2.4GHz and 5GHz networks. There is also a powerline connection from the hub. The TV can connect to the powerline network and both WiFi networks.

Problem:

I have been frustrated by variable streaming performance for some time now. After repeated attempts to understand what is going on it appears to be the case that the assigned bandwidth to each of the 2.4Ghz, 5GHz and powerline networks fluctuates.

For example, yesterday the connection test on the TV had 46mbps on the 5Ghz but the connection test on the previous day showed either 2 or 3 mbps. On that day, the 2.4Ghz network showed 45-6mbps.

Questions:

Can it be the case that the Hub is changing the bandwidth as the connection tests on the TV suggest? If so, is there anything that can be set on the router to stop this happening?

 

Many thanks in advance.

8 Replies
schnapps
Legend 5
Legend 5

Hi @agt 

When you split the 2.4 and 5ghz wifi bands on the NOW Hub 2 Router webpage Settings did you click on the Synchronise box to uncheck it and also clicked on the green Apply button for both 2.4ghz and 5ghz tab pages.

Then on your TCL TV network Settings select either 2.4ghz or 5ghz whichever has the better signal reception.

agt
Advocate

I did not. But I now have. 

I'll give it a couple of days and see how it affects it.

Thank you again for your help 😀

schnapps
Legend 5
Legend 5

Hi @agt 

If you are using the TCL TV over Ethernet with your powerline adapters then why would you go down the wifi route on the TCL TV ?

 

agt
Advocate

Hi schnapps! Thank you for helping with this.

 

The short answer is I wouldn't - it was the instability over the wired connection that led me down this merry path! 😁

 

schnapps
Legend 5
Legend 5

Hi @agt 

Have you tried unplugging the Ethernet cables in the path, then factory resetting your powerline adapters and then reconnecting the Ethernet cables to see if anything changes.

Another thing you can try has a temporary test over Ethernet is go into the NOW Hub 2 webpage Settings and see what happens if you change from Gigabit to Fast Ethernet.

agt
Advocate

I'll try that over the weekend. Thanks again!

RoyB
Legend

@agt 

Also consider this:-

https://eyenetworks.no/en/bad-apple-a-single-device-can-bring-your-wifi-down/

Set a Payment PIN on your account so that no-one but you can buy memberships on it. Check your bank accounts monthly for any other unexpected payments to Now. That way you can at least nip them in the bud, while you and Now figure out whose fault they are.
agt
Advocate

Thanks RoyB. I'll look into that as well.