Showing results for 
Search instead for 
Did you mean: 

Router shows 80mbps throughput is less than half at 36mbps

Anyone else have a router showing they have download speeds of 80 when in fact it’s less than half this when performing speed tests, this is on a wired connection, direct to my laptop, I have tried this on 4 devices, all show speed test results of 36mbps, Now tech help just say my router shows it’s receiving 80, which indeed it does, and refuse to send out an engineer, even though I have tried numerous fixes they have suggested, (changing the channel, splitting the bands, turning off broadband buddy etc etc), this problem is all over the Sky community site, many suggesting it is a Sky network issue as numerous engineers have been sent out, ( along with a ton of new routers which make no difference), and are baffled by it….as per some suggestions I disconnected completely for over half hour (this is a must) and reconnected, I was obtaining download speeds of 73mbps for 48hrs, only for it to revert back to the same old 36, all the many threads I have read with the same problem have the exact same issue…if I had speeds of 73 prev, and again, once I disconnect for a certain time there is quite obviously nothing wrong with my set up/equipment .Now broadbands attitude is, once they talk you through basic checks, they can see from their end I am receiving 80mbps to my router so end of, the problem is mine…..these broadband companies are happy to take our money but as soon as their simple quick fixes via tech support over the phone don’t work they wash their hands of you….I will be contacting Cisas, as should anyone else not getting the speeds promised in their contracts, it’s too easy for broadband companies when we simply walk away and change providers, (although after soo many wasted hours trying to sort this problem out I feel like I’m going to do just that), please post if you are having a similar issue 

Legend 5
Legend 5


It could be the router, as I understand it is simply not great. 

@chilli2 @Jayach any chance you might be able to help?

FYI that I do not work for NOW, just a NOW customer trying to help
Elite 3


I don't think the Now router is bad, as far as the modem/broadband connection is concerned, it just (apparently) has very poor Wi-Fi, but as @redchiz1 likes to point out. I've never used one.

In a case like this where the router appears to be synced at the max after rebooting, but over time hard wired speed tests seem to slow down I think I would suspect some form of local (i.e. at the customers premises) LAN congestion, maybe a misconfigured switch.

@JS If you could post your stats from the router, and let us know a bit more about what devices you are using we may be able to suggest something.



Not sure why you have invoked me here? I have long given up offering help on such topics largely because of naysayers like yourself.  😕



While it must be frustrating to have things manifestly working for you, it is equally frustrating for us that you never offer to resolve any of our questions as to exactly how those happy results might be achieved 😢

Set a Payment PIN on your account so that no-one but you can buy memberships on it. Check your bank accounts monthly for any other unexpected payments to Now. That way you can at least nip them in the bud, while you and Now figure out whose fault they are.

80 sounds a little too fast for VDSL/FTTC however f the speeds are all over the place then there could be issues elsewhere - if it happens at the same time of day it could even ben something like a central heating/water heater kicking in or out.

 I did try the Now router for a while just to see,  and found it severly lacking in wifi, and not as good with ethernet

My current router is a TP link Archer VR2800 the stats from that are as follows

  Upstream Downstream

Current Rate (kbps)1759066964
Max Rate (kbps)1758267625
SNR Margin (dB)5.76.3
Line Attenuation (dB)2513.6
Errors (pkts)15805618

speedtest sites show my speed at around 55-60 down.

Elite 3

@chilli2 wrote:

80 sounds a little too fast for VDSL/FTTC

Not really, depends on how far you are from the cabinet. I'm not on Now, but am on FTTC/VDSL.

I'm about 230 meters from mine, and I have:

  Downstream Upstream

Current Rate79945 kbps20000 kbps
Maximum Rate83373 kbps26747 kbps
Signal-to-Noise Ratio4.5 dB10 dB

Bit closer and I would have 80Mbs.

Sometimes I do get 80/20, depends on how DLM is feeling when I reconnect. 






Main concern here is the inconsistent speeds, while it should be something for Now to sort out, another possibility is could this be a provisioning error from Now?

On VDSL/FTTC there are two main speed profiles which have a theoretical maximum speed of 40 down and 10 up on the lower profile, which is often sold at a cheaper price, and a maximum ( in theory) of 80 down with 20 up on the higher speed profile.

 Could @JS have been placed on the wrong speed profile - which could result in the speed being dropped not long after a connection is established?

Elite 3

@chilli2 wrote:

 Could @JS have been placed on the wrong speed profile - which could result in the speed being dropped not long after a connection is established?

Unlikely, or it wouldn't have started out higher. Also the SNR would be very high, but as we have no (meaningful) stats from the OP, who can say.