cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Problems with HTTPS

I am having problems using the SplashID application on my iPhone and Mac. It refuses to connect to their site to sync keys - claims it cannot create a secure connection. Prior to moving to NowTV broadband I had no issues. If I turn off WiFi on my iPhone, and just use cellular, I can sync okay.

Trying to access https://www.splashid.com in a browser responds with a similar error about not being able to create a secure connection. Trying the same website at work, I can connect to the site successfully.

Is anyone else having problems connecting to certain HTTPS websites?

2 Replies
schnapps
Legend 5
Legend 5

Hi @Anonymous User

Have you tried altering or switching off the broadband buddy setting by signing into your account on here and going to My Account > Parental Controls to see if that makes any difference? 

Anonymous User
Not applicable

Thanks for the suggestion - I tried that but made no difference.  

After a bit of checking, with traceroute, I found that my local network was misconfigured. The splashid site's IP address started 192, such addresses were not being allowed out of my local network.