cancel
Showing results for 
Search instead for 
Did you mean: 
Aislinn
Advocate

Now TV Player not working/Opening on PC

Hi all

 

(My device is PC using Windows 10 which is up to date)

 

So lastnight I bought an entertainment pass to watch Game of Thrones. I downloaded the Now TV Installer, Installed the Player and went to play an episode but nothing happens.

It comes up at the top to ask permission to connect to the player, I give it permissions and then nothing happens. The only thing that happens is the little Icon in the browser tab does a quick animation but its like it never follows through into trying to open the player. 

 

When you actually open the player app, All it says is to click the link to start choosing what to watch which basically takes you in a loop

 

There is no error message

 

Me and My friend are sharing the same account and he downloaded the player and it works fine on his PC (We both use Windows 10)

 

Things I've tried to fix this:

  • I've un-installed and Re-installed the player several times
  • I've tried having the Now TV player open when clicking on the episode
  • I've using a different browser, I usually use chrome but I tried it with windows edge
  • I've tried Re-installing the player using an installer I've downloaded from a different browser
  • I've tried deleting my cookies / browser Cache
  • I've Restarted my PC multiple times
  • I've tried installing the Now TV app from the Microsoft store but that is actually defunct now and instructs you to use the player
  • I've tried running the Player as Administrator 

The weirdest thing about this is that I've used Now TV in the past when Season 8 of GOT premiered and it worked then. When I was last finished using it I just uninstalled it but now I want to come back to using it, it does this. I Can't remember if I used the App last time but obviously that isn't available anymore

 

I contacted the support team using the live chat last night and he just told me to do all the things listed above and nothing works. They said they would escalate the issue and I would hear back off them via email but I've seen in posts they don't always get in contact again.  This is really frustrating, I have scoured the forums for a fix but no one has an answer. Please help!

Labels (1)
0 Thanks
Reply
5 Replies
Aislinn
Advocate

Re: Now TV Player not working/Opening on PC

FIX!

 

The particular problem I had was the same as this guy: https://community.nowtv.com/t5/PC-Mac/Trying-to-open-TV-player-by-browser-shows-quot-Open-Fck-quot/m...

 

Its like NowTV route path got confused when trying to open the Player because the installation of NowTV itself planted a really small useless file in my C:/Users file. The file was my NowTV username. All you need to do is delete this tiny 1kb file and it fixes the issue.

 

See the forum post I linked to see if your issue is exactly the same as mine, this guy posted a video of his issue before it was fixed. 

reenie002
Advocate

Re: Now TV Player not working/Opening on PC

Hi there  @Aislinn ,

 

Would you be able to do a screen grab of where you found the file with your username. I've been trying to get this resolved via customer services but no joy and I can't find a tiny file with my username. Have tried everything to get it working and the technical team can't seem to resolve even though I've sent videos and endless info

 

The layer did used to work until I was prompted to update it

Scott14
Advocate

Re: Now TV Player not working/Opening on PC

Hi,

 

Just off the live chat with the Now TV technical team. I was having the same issue where the app kept closing after a few seconds but have now resolved it so hope this works for everyone else.

 

Essentially, the folder Cisco needs deleted from the C drive/Users/Name/AppData/LocalLow

 

At first it wasn't there for me but i had to go into control panel, appearance and personalisation, File explorer options, View then press show hidden files/folders then ok.

 

The AppData file with Locallow then appeared and I deleted the Cisco file. Then logged into Now TV on Internet explorer and the player started working fine.

 

Hope that helps!

TM_92
Observer

Re: Now TV Player not working/Opening on PC

Thankyou so much this was driving me crazy!

For anyone struggling to find the file then attempt to play the video as you normally would.
Open Task manager ctrl-alt-delete, scroll down the list of Background processes you should see NOWTV Cisco , right click, then open file location. 

Codenburger
Advocate

Re: Now TV Player not working/Opening on PC

Thank you, this solution absolutely works.

0 Thanks
Reply