cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

No connection on NowTV Hub 2 ethernet ports - DHCP not working?

I just got started with NowTV, and have a Hub 2. It all works fine, connecting via wifi directly to the hub.

 

However, I'd like to connect my own wifi router, which normally works just by connecting via ethernet to the broadband router (and hence double-natted).

 

In this case the NowTV Hub 2 is not handing out IP addresses - its as if something is wrong with its DHCP server. I also tried turning off IPv6 in the Advanced -> LAN IP Setup menu, in case that was confusing things.

 

I've also tried calling tech support, and they say there aren't really even familiar with the Hub 2, let alone terms like LAN and DHCP.

 

Any ideas here?

0 Thanks
Reply
13 Replies
Anonymous User
Not applicable

Re: No connection on NowTV Hub 2 ethernet ports - DHCP not working?

Should add, here's the basic details of the hub:

 

Manufacturer Sky
Model NR801
Firmware Version 1.00.2182.R
DSL Firmware Version A2pv6F039m1.d24m
0 Thanks
Reply
4268
Legend 5
Legend 5

Re: No connection on NowTV Hub 2 ethernet ports - DHCP not working?

@Anonymous User you might be as well searching the sky help pages. Some one else there might have been able to do what you wish to do.
Please take a moment to click thanks or marked as solution if this answered your question. I am a community contributor and pop on when I can.
0 Thanks
Reply
Andy
Legend 5
Legend 5

Re: No connection on NowTV Hub 2 ethernet ports - DHCP not working?

@Anonymous User I connected an old router as an AP on the Hub One and that worked fine, just disabled DHCP and connected via Ethernet, have you disabled DHCP on the router you're trying to connect? What reason are you wanting to connect the extra router? As a replacement AP? The Hub One was a poor wifi performer but since I've changed to Hub 2/Sky Q router I've not needed to use an alternate AP, the wifi performance of the Hub 2 is very good.

Anonymous User
Not applicable

Re: No connection on NowTV Hub 2 ethernet ports - DHCP not working?

Turns out the only reason it wasn't working was the ethernet ports were set to 'Gigagbit', whereas the cable I was using must have only had one twisted pair. I reduced the ethernet ports to what the Hub calls 'Fast', which I assume must be 100mbit. All worked fine after that.

 

I want to use my Google Wifi as it sets up a mesh network. Plus I'm only using NowTV as a stop gap until VM install the cable in 5-8 weeks - at which point I can just plug in my Google Wifi to that, and not need to change the settings on any of my devices.

Andy
Legend 5
Legend 5

Re: No connection on NowTV Hub 2 ethernet ports - DHCP not working?

@Anonymous User Got ya, glad you're sorted!

David5
Advocate

Re: No connection on NowTV Hub 2 ethernet ports - DHCP not working?

I have exactly this issue, only its my windows 10 PC and Laptop exhibiting this issue. The only solution I have found works is power cycling the hub everytime I turn my PC or Laptop On. This is becoming a real pain as it takes a good 8 mins to come back online. I cant be doing this everytime I restart my PC. Wifi is not affected

0 Thanks
Reply
Anonymous User
Not applicable

Re: No connection on NowTV Hub 2 ethernet ports - DHCP not working?

@David5 

Have you tried factory resetting the Now hub?

0 Thanks
Reply
David5
Advocate

Re: No connection on NowTV Hub 2 ethernet ports - DHCP not working?

I have only thing that works is a power cycle each time, the DCHP server goes dead on the router and refuses to reply to requests for an IP address, and tech support just said all is fine according to our end so tuff titty. And they wouldnt allow me to throw the router in the garbage and buy one.

0 Thanks
Reply
redchiz1
Expert 3

Re: No connection on NowTV Hub 2 ethernet ports - DHCP not working?

@David5 Sorry I am not sure what you mean, are you having issues connecting to the NOW Hub via Ethernet directly, or are you trying to use another router in conjunction with it? If you are trying to double NAT I doubt that the Hub supports this.

0 Thanks
Reply