Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Hub2 and Google wifi

I'm new to NowTV and I want to use my Google wifi mesh system with the hub 2.


It has set up ok BUT devices keep losing connection to the internet. LAN connection ok but then can't get through the hub.


Ideally I'd have the hub in "modem mode" which I understand is not possible with the hub 2.


Any suggestions on what settings I need to change to make my internet connection more reliable?

3 Replies
Legend 5
Legend 5

@Anonymous User 

Not being a broadband customer I can't give much advice. All I can think of for Wi-fi is to split the channels into 2.4 and 5ghz spectively.

Your Hub Two is dual-band (2.4GHz and 5 GHz). Splitting these bands to create 2 different Wi-Fi networks can help to improve the speed to your devices. Here’s how to do it:

  1. Connect your Hub Two to your laptop or computer using an Ethernet cable.
  2. Open your web browser and enter "” in the address bar.
  3. Select Maintenance and enter “admin” and “nowtv” as the username and password.
  4. Select Wireless and then 2.4 GHz Wireless Settings
  5. Scroll down to “Wireless Access Point” and uncheck Synchronise 2.4GHz and 5GHz Settings.
  6. In the ‘Name (SSID)’ box, Change the network name to distinguish it from the current network (e.g. add “_2.4G” to the current name). Select Apply.
  7. Check the network name has been updated, and then select 5GHz Wireless Settings.
  8. To be able to see easily which network is which on your devices, change the ‘Name (SSID)’ here too (e.g. add “_5G” to the current name). Select Apply.
  9. That’s it. Select Logout at the top of the screen to exit.


As for the LAN or amending the router itself I would suggest having a nosy at this thread


FYI that I do not work for NOW, just a NOW customer trying to help
Anonymous User
Not applicable



Thanks for that.


I think (but I don't know for certain) that the issue lies within DHCP or similar. All devices use the Google wifi connection, not the hub directly but they intermittently lose the ability to talk to the outside world.


If the Hub had modem mode, it would not use its DHCP or DNS and that would all be down to the Google router. So I need to mimic that


@Anonymous User 


Try turning off DHCP and DNS on the Google router, and letting the Hub2 handle these things exclusively.


No guarantees, and I don’t have either device here, but prior postings on related topics lead me to believe that this might work.


Worth a try, anyway.

Set a Payment PIN on your account so that no-one but you can buy memberships on it. Check your bank accounts monthly for any other unexpected payments to Now. That way you can at least nip them in the bud, while you and Now figure out whose fault they are.
If you take an offer that comes with a ‘free trial’ of Boost or another Membership, Cancel them straight away. You will still get the full duration of the trial, and if you decide you do want to continue with one or another of the trial products, just revisit the Cancel, and UnCancel it.