Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Hub LAN port stops working.

Moved to NowTV broadband in June 2020 from EE having been won over by the lovely salespeople. 


Anyway, the hub LAN port next to the phone line socket, keeps failing after a few days. Both are set to normal speed in settings  (not 'fast' which is gigabit) , cable is quality Cat5 from CPC. All works from power on, then 3, maybe 4 days later, the port stops working. The orange  LAN port led goes out (no live connection) and the green light goes out (no data). Both leds stay off. Power hub off, wait 1 minute, power on, all works again, for 3,4 days.. and so on.


Tried different cables. still same.


I know it's not my devices because if i switch devices and  cables - or both -  on both ports, the device working for weeks on the good port, now fails and the device failing before, now works all the time. It IS the port .


How do i get a new router please NowTV?

5 Replies
Legend 5
Legend 5

Hi @Anonymous User 


No problems with my NowTV Hub Router 2 which i have been using it for over 2 years now, where i use one Ethernet port directly to my Youview 4K box where the second Ethernet port off the Router is connected to an 8 port unmanaged Gigabit switch.


I am guessing you have tried pressing the reset button on the back of the Router for 10 seconds after temporarily removing and disconnecting your Ethernet cables from both your sources and Hub Router and reconnecting the cables again before pressing the Hub Router reset button.


You may have a faulty Router with an inherent fault on the Ethernet ports.


To reach out to NowTV to see if they will supply you a new replacement Router, then use the telephone number for the Broadband Team in the link page below. 


Should you have an old Sky Router lying around, then use that whilst NowTV hopefully sorts you out.

Anonymous User
Not applicable

yes, all power cycles tried. it's not as simple as that, but thank you for your reply. 


Anonymous User
Not applicable

Did you ever get this sorted @Anonymous User ?


I've had my Hub 2 for a couple of years and been fine, but this last few days I have been having this EXACT same problem.........  Have powerline device connected to this port and spent ages resetting and updating 3 extenders before I realised it was the port 😞


Suspect only fix is to try get a new router, so just emailed support


Hi, did you get this sorted? I am having the same issue 

Legend 5
Legend 5


Assuming you have tried a factory reset to the router, I would suggest calling the broadband team using the number in my signature below. 

FYI that I do not work for NOW, just a NOW customer trying to help