Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Freesat on demand not working with NOW

Hello Community


We have a bizarre but extremely annoying issue… Ever since my mum switch to NOW TV she has not been able to use OnDemand services on Freesat.

NOW TV say that there is nothing wrong with the broadband… However, if I take her Freesat box to my house right next door and plug it into my BT router it works just fine. My own Freesat has no problems but if I take it into my moms house and connect to her NOW TV router we have the same problem of no on demand services.


I am being told that there must be a problem with the Freesat box, however as demonstrated it does work in another house and it does seem too much of a coincidence that this issue began the moment we switched provider to NOW TV. 


We have tried everything from factory reset to checking any security blocks on the line but nothing is working and there is not much point in buying a new box, as we have been advised today, as my new box does not work at her house either!


Has anybody else had this experience? 

Legend 5
Legend 5

Hi @Anonymous User 


I don't know if the WPS button will work, but make sure you are also on the Freesat relevant screen settings page, because it might ask you to connect to a Sky / NOW wireless network.


Can you get away with Ethernet on the Freesat box if you are going around in circles with wifi ?


Sorry i can't help any further, because i don't own a Freesat box (only a Youview box which works great with regards to the Apps over hard wired Ethernet on the NOW Hub 2 Router).



Anonymous User
Not applicable

That does sound like a very strange problem. When you say it doesn't work does it at least connect to the router? Go into the network settings on the freesat box and see if it is getting an I.P. address.


@Anonymous User @Anonymous User @schnapps 


Just to clarify the issue a little, there is no actual such thing as’ Freesat on Demand’, but rather, what we are talking about is a Freesat device with internet catchup apps.


Which Now Broadband refuses to service, for some reason.


Though I doubt that this is because it is a Freesat device, particularly; there is something else here that Now doesn’t like.


So it would seem important to identify what make and model of Freesat device this is, which nobody has so far done.


(Of course, if this is happening on several different models of Freesat box, then I’ll get me coat).

Set a Payment PIN on your account so that no-one but you can buy memberships on it. Check your bank accounts monthly for any other unexpected payments to Now. That way you can at least nip them in the bud, while you and Now figure out whose fault they are.
This week, I are genrally been watching epsidoes on my Sasmung TV

I am definitely not a technical person and I’ve got a similar problem .

I was with Now 2 years ago and everything was fine.

I’ve always had to use Ethernet cables as I appear to have a poor signal.

I watch tv and OnDemand through the freesat box and via a dish outside

I’ve switched to Now today and OnDemand tells me it’s loading then says should take one minute.  Been trying for hours and it’s still not coming on.

switched everything off and back on nothing 

I only want broadband to watch OnDemand and have a really bad feeling that my older tv and Freesat box are not compatible and 

Please help me if you can