cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Estimated average 35-75mbs. Actual 4mbs

Im paying extra to have the faster speed which was estimated at 35-75mbs. Thats up-to 75mbs.

Speedtest rates my speed at just over 4mps and upload at 2mbs.  Im sorry but '4' is not 'up to 75' by anyones book.

It was installed yesterday.  Cut my bill by 80% to match? I cant even watch a youtube vid with this. Very dissapointed.

Surely there must be something wrong?

1 Solution
Anonymous User
Not applicable

Hey there,

To answer your question,  the quick answer is yes.

 

Installed monday. Practically unusable speeds.  pages taking a minute to open. No point in even turning on my console. Speedtest website is showing me 4-25mps. 25 was the very highest i got once. Actual speed was so slow, it was taking the speedtest wepage over a minute to load the ads. Actual average download speed from various sources was stupid slow like 10-100kps

 

Friday morning I get up, run speedtest. and I get the full 75mbps. I find a fast download source and try it, and downloaded at almost full speed (75mbps).

 

Needless to say I wont be leaving, Ive been downloading toaday without glitches. Everything i want to do on the connection is good and working and im much happier now.

 

Now i can move on to the issue of why they havent taken the payment from my account?

View solution in original post

11 Replies
Anonymous User
Not applicable

if i cant speed this up tonight im leaving. tommorrows too late.

 

il be reviewing ISPs. check my site soon. http://tortoisehead.atwebpages.com/

 

Tony-D
NOW Team Member
NOW Team Member


@Anonymous User wrote:

if i cant speed this up tonight im leaving. tommorrows too late.

 

il be reviewing ISPs. check my site soon. http://tortoisehead.atwebpages.com/

 


@Anonymous User Any improvements? Are you using Wi-Fi or hardwired? Thanks

Anonymous User
Not applicable

Hey there,

To answer your question,  the quick answer is yes.

 

Installed monday. Practically unusable speeds.  pages taking a minute to open. No point in even turning on my console. Speedtest website is showing me 4-25mps. 25 was the very highest i got once. Actual speed was so slow, it was taking the speedtest wepage over a minute to load the ads. Actual average download speed from various sources was stupid slow like 10-100kps

 

Friday morning I get up, run speedtest. and I get the full 75mbps. I find a fast download source and try it, and downloaded at almost full speed (75mbps).

 

Needless to say I wont be leaving, Ive been downloading toaday without glitches. Everything i want to do on the connection is good and working and im much happier now.

 

Now i can move on to the issue of why they havent taken the payment from my account?

Tony-D
NOW Team Member
NOW Team Member


@Anonymous User wrote:

Hey there,

To answer your question,  the quick answer is yes.

 

Installed monday. Practically unusable speeds.  pages taking a minute to open. No point in even turning on my console. Speedtest website is showing me 4-25mps. 25 was the very highest i got once. Actual speed was so slow, it was taking the speedtest wepage over a minute to load the ads. Actual average download speed from various sources was stupid slow like 10-100kps

 

Friday morning I get up, run speedtest. and I get the full 75mbps. I find a fast download source and try it, and downloaded at almost full speed (75mbps).

 

Needless to say I wont be leaving, Ive been downloading toaday without glitches. Everything i want to do on the connection is good and working and im much happier now.

 

Now i can move on to the issue of why they havent taken the payment from my account?


@Anonymous User Glad to hear it's all sorted 🙂 Now what's this about a payment then?

Anonymous User
Not applicable

Hello, thanks for reply. it seems the payment wasn't taken. So now it's been taken by a subscription in struggling to cancel. It looks like I can pay manually on the website. I just hope it gets taken at the proper time next month.
It seems all just teething problems, the connection has been great since it sped up. I really wanted to stress that to other users.
Tony-D
NOW Team Member
NOW Team Member


@Anonymous User wrote:
Hello, thanks for reply. it seems the payment wasn't taken. So now it's been taken by a subscription in struggling to cancel. It looks like I can pay manually on the website. I just hope it gets taken at the proper time next month.
It seems all just teething problems, the connection has been great since it sped up. I really wanted to stress that to other users.

Yeah i know what you mean @Anonymous User The bill should come out on the date you go active or maybe the day after but please come back to me on here if your next bill doesn't come out on the right date. Thanks 🙂

Anonymous User
Not applicable

Hey. Im not sure whats happened here. But i have just gone to pay manually and..... Its already been paid. im very confused. Have they paid it gratis maybe? Whatever happened..everything is good now.
Anonymous User
Not applicable

I cant go any longer without sleep. Nobody answers the phone because there is not the correct option. It just hangs up when i press hash. 

The engineer left the lid off the box on the post outside. It windy and noisy.

If i cant get through im sure another company would be glad to listen. Its driving me insane. along with the fact that im struggling to stream youtube.  Why dont you answer the phone???

Anonymous User
Not applicable

same with you, i'm a new customer decent download of 15-20 but upload of 0-1mpbs. Spoke to plenty of livechat/calls and even manager. Not once did they offer to send an engineer even if it maybe an external problem. 

Tony-D
NOW Team Member
NOW Team Member


@Anonymous User wrote:

same with you, i'm a new customer decent download of 15-20 but upload of 0-1mpbs. Spoke to plenty of livechat/calls and even manager. Not once did they offer to send an engineer even if it maybe an external problem. 


@Anonymous User So sorry for the delayed response. Have you seen any improvements lately? Thank you.

Anonymous User
Not applicable

Still same speed, it's been 10 days now so will be contacting.