Showing results for 
Search instead for 
Did you mean: 

Broadband not reaching all rooms



We are in a 3 storey house and originally the broadband wasn't reaching the top floor and there was an error with our connection. An engineer was sent out the next day (Thank you!) and it has definitely improved the wifi, we have moved the box to the second floor and it's connected to the main plug, rather than an extension, but still not all rooms are receiving good wifi, meaning we have to disconnect to it, to receive anything on our phones etc - we are on a super fibre broadband plan.


Will we need to now by a booster, or is this something NOWTV will provide?


Thank you

0 Thanks
2 Replies
Legend 5
Legend 5

Re: Broadband not reaching all rooms


Have a look at this link for changing the Wi-fi channel to 5GHz which provides a more reliable signal.


Your Hub Two is dual-band (2.4GHz and 5 GHz). Splitting these bands to create 2 different Wi-Fi networks can help to improve the speed to your devices. Here’s how to do it:

  1. Connect your Hub Two to your laptop or computer using an Ethernet cable.
  2. Open your web browser and enter "” in the address bar.
  3. Select Maintenance and enter “admin” and “nowtv” as the username and password.
  4. Select Wireless and then 2.4 GHz Wireless Settings
  5. Scroll down to “Wireless Access Point” and uncheck Synchronise 2.4GHz and 5GHz Settings.
  6. In the ‘Name (SSID)’ box, Change the network name to distinguish it from the current network (e.g. add “_2.4G” to the current name). Select Apply.
  7. Check the network name has been updated, and then select 5GHz Wireless Settings.
  8. To be able to see easily which network is which on your devices, change the ‘Name (SSID)’ here too (e.g. add “_5G” to the current name). Select Apply.
  9. That’s it. Select Logout at the top of the screen to exit
0 Thanks

Re: Broadband not reaching all rooms

Now routers are poor for WiFi


Invest in a Mesh WiFi like BT Whole Home WiFi AC2600 or similar. 

0 Thanks