cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Advocate

Amazon Echo won’t connect to NOWTV Hub2

Hi all,

 

I’m having issues with getting my (2nd gen) echo to connect to my NOWTV internet in my new house. I have tried restarting both the echo and router but to no avail. I put in the password and it just comes up saying “your echo is having problems connecting to WiFi” or something to that effect.

I brought it back to my parents’ house and it connects to their Sky hub fine - which is the exact same router. Has anyone else had this problem and found a solution? I’m moving in properly this weekend so really want to get it working, especially as I have some fancy new lights to work with it! 

Cheers,

Hannah 🙂

0 Thanks
Reply
4 Replies
Highlighted
Legend 5
Legend 5

Re: Amazon Echo won’t connect to NOWTV Hub2

Hi @Foxxed 

 

I don't own or have any experience with regards to an Amazon Echo, but with regards to issues when connecting devices over wifi on the NowTV Hub 2 the two things that i would try is splitting up the 2.4ghz & 5ghz wifi band on the Hub Router by following these instructions below.

 

Your Hub Two is dual-band (2.4GHz and 5 GHz). Splitting these bands to create 2 different Wi-Fi networks can help to improve the speed to your devices. Here’s how to do it:

  1. Open your web browser and enter "192.168.0.1” in the address bar.
  2. Select Maintenance and enter “admin” and “nowtv” as the username and password.
  3. Select Wireless and then 2.4 GHz Wireless Settings
  4. Scroll down to “Wireless Access Point” and uncheck Synchronise 2.4GHz and 5GHz Settings.
  5. In the ‘Name (SSID)’ box, Change the network name to distinguish it from the current network (e.g. add “_2.4G” to the current name). Select Apply.
  6. Check the network name has been updated, and then select 5GHz Wireless Settings.
  7. To be able to see easily which network is which on your devices, change the ‘Name (SSID)’ here too (e.g. add “_5G” to the current name). Select Apply.
  8. That’s it. Select Logout at the top of the screen to exit.

Also go into My Account > Settings & Pins whilst logged in on here and temporary switch off the Broadband Buddy  Settings.

 

Other than that i am out of ideas if your Amazon App on your phone is up to date.

 

Hopefully an Amazon Echo owner who uses NowTV Broadband will come to your rescue.

 

0 Thanks
Reply
Highlighted
Advocate

Re: Amazon Echo won’t connect to NOWTV Hub2

@schnapps thanks for your reply! I’ll try and remember to take my laptop with me tomorrow so I can give that a go when I go over to do more unpacking (deep joy 🙄😂). Will let you know if I have any success with it or not! 😊

0 Thanks
Reply
Highlighted
Advocate

Re: Amazon Echo won’t connect to NOWTV Hub2

Still no luck - anyone else got any fixes they've found for the same issue? Getting rather frustrating now!

0 Thanks
Reply
Highlighted
Legend 5
Legend 5

Re: Amazon Echo won’t connect to NOWTV Hub2

Hi @Foxxed 

 

If you get no response on here from any Amazon Echo owners using NowTV Broadband, then if it was me i would look on the Sky Community Forum by entering in Amazon Echo in the search box for any results, where there would be more Amazon Echo owners using Sky Routers (similar setup to NowTV Routers).

 

Alternatively give the NowTV Broadband Team a call, where i believe their phone lines are open between 8am and 7pm during the Covid-19 lockdown.

 

I found this article on the internet (don't know if it would help in any way).

 

https://www.guidingtech.com/amazon-echo-not-connecting-to-wi-fi/