cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
AndyF777
First Poster

Subtitles

Hi, 

 

Subtitles have suddenly appeared on my Now tv app which I watch through my smart TV.

I can't find any settings menu in the app to disable them.

 

Please help 🙂

Labels (1)
0 Thanks
Reply
11 Replies
schnapps Legend 4
Legend 4

Re: Subtitles

Hi @AndyF777

When watching nowtv and you see the subtitles on screen, if you press the pause button on your remote an info bar will pop up and on the far right should be a bubble speach icon, where if you highlight and click on it, the subtitles should then hopefully disappear.

0 Thanks
Reply
BigNick1
Contributor 2

Re: Subtitles

Hi  @schnapps 

There are quite a few posts appearing about this problem, i also now have it on my LG tv. For some reason subtitles seem to be ON by default instead of OFF, and there's no main setting to override this so you have to turn them off each time you start watching something on the app. Do you know who to tag about this so hopefully it will be fixed??

 

0 Thanks
Reply
schnapps Legend 4
Legend 4

Re: Subtitles

Hi @BigNick1

Yeah i have noticed on the forum recently that numerous people have mentioned across a lot of different platforms that subtitles are switched on by default.

I only watch nowtv on my nowtv boxes or Roku Stick Plus and because there is an option in menu settings on my devices to switch captions off i haven't had any problems with the subtitles showing on my screen.

I don't own a smart TV with the inbuilt NowTV App and can only suggest until the NowTV Team look into this further and come up with a fix, is to double check in your LG TV settings there is no captions or subtitles disable options, try pressing the subtitles button on your TV remote if available and what other people have been trying is pausing nowtv content showing subtitles and when the info screen pops up navigate to the bubble speach icon (far right) and switch it off.

Will tag @Tony-D of the NowTV Team on here and will ask him to pass this problem with default subtitles showing on a wide range of devices to their Tech / Software Team.

NOW TV Team Tony-D
NOW TV Team

Re: Subtitles

Yeah there should be a wee speach bubble on the NOW TV display. Underneath the timeline it should be. I'll have to have a word with the guys who develop this specific app and see what the problem is to be honest. @schnapps @BigNick1

schnapps Legend 4
Legend 4

Re: Subtitles

Thanks @Tony-D

Recently i have responded or seen posts on the forum by LG smart TV owners, Xbox owners, PS4 owners and IOS and Android mobile device owners who have flagged up that subtitles are switched on by default. 

0 Thanks
Reply
BigNick1
Contributor 2

Re: Subtitles

@Tony-D @schnapps

Yep, i have been using the speech bubble to turn them off, the problem seems to be they are always set to ON by default instead of OFF as they should be in the LG Nowtv app. I hope this can be fixed.

0 Thanks
Reply
NOW TV Team Tony-D
NOW TV Team

Re: Subtitles


@BigNick1 wrote:

@Tony-D @schnapps

Yep, i have been using the speech bubble to turn them off, the problem seems to be they are always set to ON by default instead of OFF as they should be in the LG Nowtv app. I hope this can be fixed.


Yep, i was afraid of this @BigNick1 I don't even think there is an option to turn them off completely within the LG App. I'll have a word with these guys anyway and see if they can issue a hotfix or a rollback to previous versions as they seemed to work just fine.

BigNick1
Contributor 2

Re: Subtitles

@schnapps @Tony-D

Thanks for looking into this, and no, there is no other option to turn them off completely only by the speech bubble when you start watching something. It seems to be across a few devices now, at least with my old black box i can turn them off and they stay off!

NOW TV Team Tony-D
NOW TV Team

Re: Subtitles


@BigNick1 wrote:

@schnapps @Tony-D

Thanks for looking into this, and no, there is no other option to turn them off completely only by the speech bubble when you start watching something. It seems to be across a few devices now, at least with my old black box i can turn them off and they stay off!


Yeah it weird that there is no definitive option to turn them off. I'll let you know as soon as i here back anyway sure @BigNick1