cancel
Showing results for 
Search instead for 
Did you mean: 
Jon
Observer

Sky Sports Blurry on 4k Roku Stick - SOLVED!

I used to have a normal NOWTV Stick and recently upgraded to a 4k Roku stick. Everything works great but when I went on to Sky Sports using the NOW TV app the picture was really grainy. It seemed to be fine for around 4 seconds and then looked like the camera was really muddy. At first I thought it was actually a bad camera but then checked another channel and the same thing happened. It almost looks like camoflauge netting being over the camera.  I have seen lots of similar posts on the forums without any solutions. 

Basically, the issue is the NOW TV app and sky sports channels do not support 4K. I believe you probably need a sky subscription for this. 

Replacing the stick will not resolve this - this is normally what customer service advice but it is not the issue. To resolve it - you go to the home page on the roku stick and find the display settings. You then reduce the display setting to 1078 rather than any of the 4k settings. This solved the issue for me. 

The 4K seems to work fine on all other apps e.g. cinema / entertainment / netflix etc.

2 Replies
schnapps
Legend 5
Legend 5

Hi @Jon 

Glad there is a PQ improvement for you by forcing 1080p on your 4K Roku when watching NOW live Sky Sports.

I have tried this in the past on numerous occasions with various devices and for me the camouflage picture artefacts are still there for me when watching live Sky Sports.

Thought I would give it another go after seeing this post of yours, unfortunately it is still the same for me 😡 .

What I have noticed in my setup when comparing two different 4K televisions is that my OLED 10 bit TV seems to mask the camouflage artefacts better (still noticeable to my eyes) when comparing to an 8 bit mid range LCD television that I own where the camouflage artefacts is more pronounced.

Anyway glad it solved it for you.

redchiz1
Elite 2

@Jon

Bear in mind that NOW does not support 4K at all, so I can only imagine that your 4K TV is struggling with upscaling, perhaps check the settings on the TV?