Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

NowTV app not working again after Roku update

Since Roku express plus updated on 22 April, NowTV app has refused to work.

spent a couple of hours online with Roku support and tried all the fixes - remove app, rebooting, reinstalling, etc, etc

The fixes suggested from NowTV also don’t fix

It appears the NowTV app needs an update to make it comparable with the latest Roku Plus update

The app works fine on other platforms 

Could @Anonymous User investigate and advise


Legend 5
Legend 5

@Anonymous User 

You’ll need to jump onto live chat or email support for NOW to take notice.


Live chat, make sure you click “chat online” within the green box and not “get help quicker” as this is a bot.

Email address for support is in the below picture.


FYI that I do not work for NOW, just a NOW customer trying to help
Anonymous User
Not applicable

We're facing the same problem. We have three Rokus, Now has stopped working on two of them. Just gets stuck at the logo/loading screen.


I think both Rokus on which Now doesn't work updated in the last few days. The Roku that does work hasn't been switched on for a few days so I presume it hasn't updated yet.

Champion 2

@Anonymous User @Anonymous User Are you still having problems?


I haven't used NOW on my Streaming Stick+ for a while so I thought I'd check. And everything is working fine.


Software version 11.0.0; Build 4184


NOW app version 6.6.1

Anonymous User
Not applicable

Thanks @redchiz1, I just checked and we're still having the same problem.


They're all Roku Express boxes, the two that don't work with Now have Roku OS software version 11.0.0 build 4184-51. The one that does still work is on 10.5.0 build 4208-51.


The Now app is version 66 build 1 on each device. No further Roku OS or Now updates are available.


Last night I tried removing and then reinstalling Now but it didn't solve the problem.


I've also just noticed that All4 doesn't work on the same two devices with Roku OS v11 but does work on the device with Roku OS v10.5. It's a similar problem, it hangs on the loading screen.

Champion 2

Hmm, OK, have you tried resetting the affected devices? I know this is a bear with having to re-register everything, perhaps just try one to be getting on with and see what happens?


We had issues with NOW Sticks in December, got to the logo screen and froze. 


After many hours chasing CS and drop outs in chats it worked its way to Tech, sent videos and I think it was near 5/6 week in all it was fixed it was over Christmas


Top tips


1. Preferred email over chats, email be a little slower but less frustrating, you dont repeat yourself as often and all though this is the 21st century and NOW are a streaming/internet company chat drop outs occurred regularly 


2. If your keen to view try a non Roku device we found PS4 and Firestick worked OK, guessing other alternatives would be fine as well.


Good luck



Anonymous User
Not applicable

I'll wait a couple more days to see if this gets resolved, but if not I'll try resetting the box.

Anonymous User
Not applicable

I've factory reset one of the devices and it hasn't helped, still have the same problem.

Champion 2

@Anonymous User Sorry to see that, have you reached out to NOW and/or Roku to see if they can help?