Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

Now app “pending”



I have the now app on my Sony smart tv. It’s been working fine for a long time. Yesterday it said the app needed updating. When I try and update the app says it is “pending” but it’s not doing anything….


I have removed the app and tried to reinstall but have the same “pending” issues.


any ideas??

Legend 5
Legend 5

Hi @Anonymous User 


I think i encountered this myself on my Amazon Fire Stick NOW App.


I can't remember if i just unplugged the power to the Stick for a minute and tried again or i actually factory reset the Stick.


Factory resetting your TV would be a pain in the backside, where you would have to setup the television again from scratch.


If your television has been calibrated write down the full picture settings used.

Legend 5
Legend 5

@Anonymous User 

Hold the ok button for a few seconds, you’ll see a pop up with the option to restart. This will effectively power down and restart the TV. 
This is something I need to do a few times a week just to give it a kick up the rear.

Hopefully it’ll sort it out. Saves you unplugging the TV. 

You could also try unplugging the router for a few minutes.

FYI that I do not work for NOW, just a NOW customer trying to help