cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous User
Not applicable

ooops something went wrong (with everything?)

I am completly unable to log into nowtv from any device on my home broadband, everything gives me a similar message 

Oops something went wrong

Sorry, something went wrong at our end, please refresh this page to continue.

But It's been happening for over a week now, and I can't even log in to view my account information, let alone watch anything, even the status check page gives me this error.

Not been able to get on live chat once. This happens on mac, xbox and PC, I can log in via a phone off wifi, but as it's a new device i can't change it yet this month so i can't watch anything on that either.

1 Solution
schnapps
Legend 5
Legend 5

Hi @Anonymous User

On my previously link, can you access on the page "drop them a message" ?

Have you tried a different internet browser with your smart phone making sure the ad blocker is disabled and Javascript is enabled on your phone ?

When i notice somebody from the NowTV Forum Team has logged in on here i will tag them, so they can assit you further.

View solution in original post

12 Replies
schnapps
Legend 5
Legend 5

Hi @Anonymous User

Who is your ISP ?

Are you using any VPN service on your router ?

Have you tried switching the power off to your router for about 20 minutes to allow the router to automatically acquire a new IP address ?

With regards to changing your devices on your account, if you haven't any device swaps left this month, then you will need to speak to live chat (perhaps try using your smartphone) and ask them for a further extra device swap this month or alternatively ask them to reset all your devices.

Link below to live chat.

https://help.nowtv.com/contact-us/managing-my-devices

Anonymous User
Not applicable

thanks for the reply, I am with plusnet, I am not using a VPN, and I powered off the modem and routher all night. Still no luck.

I still haven't managed to talk to anybody via live chat yet.

Anonymous User
Not applicable

you know what, does anybody have an actual email address i can leave a complaint?

If i can never get on to live chat, is my only other option, seriosuly, sending a letter by post... 

Anonymous User
Not applicable

Customer service, or rather disservice, is appalling on NowTV.

schnapps
Legend 5
Legend 5

Hi @Anonymous User

On my previously link, can you access on the page "drop them a message" ?

Have you tried a different internet browser with your smart phone making sure the ad blocker is disabled and Javascript is enabled on your phone ?

When i notice somebody from the NowTV Forum Team has logged in on here i will tag them, so they can assit you further.

schnapps
Legend 5
Legend 5

@Anonymous User

Could somebody from the NowTV Team help @Anonymous User 

Anonymous User
Not applicable

ah ha! you got it! I was eventually able to get onto the chat and watch shows when i was using icognito mode, which i thought was odd.

unfortunitly chat just said they would get back to me as it was a known issue...  

But seeing your post and putting two and two together it must have have disabled the ad blocker in incognito mode... all my browsers are set up the same!

 

well done schnapps you have solved it, odd that it just stopped working one day. but it works now. Thanks 

 

Anonymous User
Not applicable

I am now having this same issue since yesturday Friday Night.

Anonymous User
Not applicable

I’ve got the same problem. I can’t get in to set up my Now TV box because I just keep getting this error message. 

Anonymous User
Not applicable

I have bought a stick last week got to the set up stage of putting in the code on the tv (which I’m doing in my phone and my laptop) I have tried and tried and just keep getting the “oops something went wrong our end please refresh the page to continue” 

I have tried different browsers on my phone any ideas anyone I’m not very good at technology 

OILCAN
Scholar

Hi mate, when l started up with Nowtv a few months ago and connected my 1st stick, got a similar message.  I hadn't gone far enough in the set up process and validated the pass.  Once that was done it worked.  Not sure if that's your issue, but worth checking.

Anonymous User
Not applicable

Please delete post