cancel
Showing results for 
Search instead for 
Did you mean: 
bacillus
Expert

What's up with this new version of NowTV player 6.1.0.0?

Was told an update was available when I signed on to view a show so I updated to the latest version.

What a downgrade this version appears to be as it's laggy to start playing as I'm waiting up to a minute before the video shows up and even closing it takes about 10 seconds. This never happened with the previous version.

In view of the issues, I looked in Program and Features and there were two versions of cisco guard, one from today and one from the earlier version. I tried deleting the earlier version but that didn't help the laggyness of the application so I uninstalled the now tv program and ciscoguard and reinstalled with a fresh copy of the Now Tv player exe. Unfortunately this didn't make an iota of difference with the laggyness.

I'm using Win 10 pro version 1803 build 17134.320 fully updated.

25 Replies
Anonymous User
Not applicable

I also upgraded, and mine stop working, and gave the message "oops somethings went wrong", On Npw TV website's advice i re-installed NowTV player, But it still isn't working. V annoyed.

roguexuk
Scholar

Yeah. I'm the same.

This happens almost everytime I have to update the player - it simply doesn't work at first. I usually have to five it a day or so.

But this time around, I'm on my second day, plus have re-started but no joy.

Think I will have to try re-installing, cleaning out the cache and starting again.

Tony-D
NOW Team Member
NOW Team Member


@bacillus wrote:

Was told an update was available when I signed on to view a show so I updated to the latest version.

What a downgrade this version appears to be as it's laggy to start playing as I'm waiting up to a minute before the video shows up and even closing it takes about 10 seconds. This never happened with the previous version.

In view of the issues, I looked in Program and Features and there were two versions of cisco guard, one from today and one from the earlier version. I tried deleting the earlier version but that didn't help the laggyness of the application so I uninstalled the now tv program and ciscoguard and reinstalled with a fresh copy of the Now Tv player exe. Unfortunately this didn't make an iota of difference with the laggyness.

I'm using Win 10 pro version 1803 build 17134.320 fully updated.


@bacillus

@Anonymous User 

 

Very weird guys, i'm not even in the house to test this right now but i will be in tonight. It was playing fine a few days ago so i can't see why an update could be so backwards. Hopefully it just requires a simple hotfix. Hows your CPU usgae looking whne you go to task manager while playing guys? Hopefully cicso isn't becoming the processor eater it once was lol.

bacillus
Expert

My cpu usage is about 60% when viewing so my processer has reasonable spare capacity.

Anonymous User
Not applicable

I still can't get anything to start playing on the now tv player, so when i check the CPU it's arround 15-20%. I really don't know what's up with it.

Tony-D
NOW Team Member
NOW Team Member


@bacillus wrote:

My cpu usage is about 60% when viewing so my processer has reasonable spare capacity.


@roguexuk @bacillus 

 

Your CPU definitely seems to be sweet when trying to run/play at least so it's not that. I'll have it sent off now and see if there is any fix to be implemented. Hopefully sooner rather than later.

Anonymous User
Not applicable

Installed 6.1.0.0 on two PC's now. Both fail to start nowTV app with display. One had never had app installed so no cache to clear. Think the app is broken in the display part.

bacillus
Expert


@Anonymous User wrote:

Installed 6.1.0.0 on two PC's now. Both fail to start nowTV app with display. One had never had app installed so no cache to clear. Think the app is broken in the display part.


I have to wait for a little over a minute before I get any video showing up.

Anonymous User
Not applicable

Done the waiting. Nothing. Got a box too so I guess thats ok, but if it has a windows app is it too much to ask that it works. I have no issues with netflix working on browser. It just gets to me. Its not the only time either. Ranting sorry.

Anonymous User
Not applicable

I just changed my background to a pre insalled one and it cured the problem.

Anonymous User
Not applicable

I seem to get the attached error code

Anonymous User
Not applicable


@Anonymous User wrote:

I seem to get the attached error code



I believe that error is due to the fact that you have windows aero disabled on windows 7. Try turning on windows aero by enabling the transparency checkbox in themes

04_disabling_transparency_w7_thumb

 

 

Anonymous User
Not applicable

It's taken over a week to discover such a silly thing was stopping it working.

Would have been good to get info from the Help button.

 

Anyway many thanks

 

Anonymous User
Not applicable

WTF?  Why do I have to switch off the classic scheme to Telly-tubby land in-order to use transparency?  Why does the player need to have that?

Anonymous User
Not applicable

Well done nick-michael !!!! Neither Now TV on social media or, indeed, their so called 'Tech Experts' on live chat were able to identify such a simple resolution! Still beats me why Aero should be needed, never was prior to 6.1.0.0, but at least I am now able to watch the sports channels again!

Thank you!

Anonymous User
Not applicable

Don't know how you came to this conclusion, but it works for me.

Anonymous User
Not applicable

It worked in the beginning, now I’m getting error message to change to aero theme, which I’ve done, still getting same message ☹️
Anonymous User
Not applicable

Thanks,  Tried that and is working now.

Anonymous User
Not applicable

I was playing around with this a bit more, and it seems like you don't necessarily need to have transparency enabled, you just need to make sure that you are using one of the 'Aero' themes that support transparency (even if you have it disabled, it seems to still work)

 

aero.PNG

Anonymous User
Not applicable

Why is that causing a problem? seems like that shouldn't be a requirement of any update since aero is useful waste of CPU.