cancel
Showing results for 
Search instead for 
Did you mean: 
MistyV
Advocate

Trouble with MS Remote desktop

Hi,

 

I am trying to connect to my work server, from home.  This is a two step process - 1) Cisco VPN, which connects fine, and 2) Microsoft Remote Desktop  - which does not connect, and gives me the following error message: 

 

We couldn't connect to the remote PC. Make sure the remote PC is turned on and connected to the network, and that remote access is enabled. If this keeps happening, contact your network administrator for assistance.  Error code: 0x3000016

 

My work IT have spent 5+ hours on this and have concluded that something in NowTV broadband security settings (?) is blocking the remote desktop.  To confirm this, I tested it on with another internet provider in our local library.  Same laptop, same vpn, same remote desktop software and it worked.  The only difference is the broadband provider.

 

NowTV helpdesk say the following: From NOWTV broadband: There's no real setting with us that would be blocking an application from connecting, the only setting we can advise customers to change is with regarsds to wireless channels, wo don't actually provide support for any vpn on here you see

 

I have tried several different wifi channels and it doesn't work.  Same error message.

 

I have already added the addresses the remote desktop is trying to connect too, to the safe sites via Broadband Buddy and this makes no difference.  I can't connect, and get the same error message.

 

Has anyone else experienced this?  Solved this?  

I am using the latest version of all OS / software.

 

Thanks.

Labels (1)
0 Thanks
Reply
11 Replies
schnapps Legend 5
Legend 5

Re: Trouble with MS Remote desktop

Hi @MistyV 

 

Have a read of this help guide where there is a section about accessing a work VPN from home.

 

https://help.nowtv.com/article/broadband-buddy-troubleshooting

 

Edit - Sorry i missed the bit that you have already tried this 😠.

0 Thanks
Reply
MistyV
Advocate

Re: Trouble with MS Remote desktop

Yes, I tried that.

I pushed the helpdesk again, and they are now suggesting Port Forwarding.  That is getting beyond my levels of technical competence, and as it's a home router, work won't support this.

 

 

0 Thanks
Reply
RoyB Legend 5
Legend 5

Re: Trouble with MS Remote desktop

@MistyV  

 

Would I be correct that under Remote Desktop, the work server is trying to connect back to your laptop, rather than your laptop trying to connect to the work server?

 

If you were in the office, would you still have to use Remote Desktop? (Unless you would be on the device you are remoting to, which means it would itself be a client, as above, and not a server at all).

 

If not, I might have an opinion on how crap an arrangement that is for remote access; for me, WFH, the VPN entirely suffices, and puts me on the same footing as if I was in the office.

 

But yes, Port Forwarding is the answer. I used to use a Slingbox, and my BT Home Hub required port forwarding; when I swapped that, for an unrelated reason, for a Netgear Nighthawk still on the same BT broadband line, I did not have to port forward at all.

 

A home router expects to be a client device, initiating requests and accepting replies, so a good security measure is to ignore any incoming traffic that comes from outside without having been requested. You don’t, normally, want to be a server, accepting just anything that comes along, as there is a lot of bad stuff out there, trying to get onto people’s laptops.

 

But in this case, you do want to allow unexpected traffic, probably on port 3389, and ‘Port Forwarding’ just means that you tell the router that there will be unexpected traffic on this port, and to allow it through.

 

You will need to ask your work IT which port(s) and protocols Remote Desktop uses (they ought to know this).

 

I don’t know if Broadband Buddy lets you make the required changes, maybe called port forwarding, maybe called virtual server, maybe called creating a firewall exception for that port? That would be simplest.

 

Otherwise, here’s a good free resource, which you can try following, to work directly on the router, if the needed settings are available to you.

 

And as a third option, here’s a very comprehensive commercial resource. They would very much like to sell you their software (purely to make things easier for you, you understand) but still describe how to do things manually nevertheless. And as a last resort, if you buy their software and still can’t get things to work, they guarantee to make it work for you at no extra cost, which is a pretty good offer. And for them, gives them a new potential market, so everybody wins 😛


If my posting answered your question, please click ‘Accept Answer’
(As long as you started the thread, and haven’t already accepted an answer)
If you liked my posting, please click ‘Thanks’ (the thumbs-up icon)
If you disagree with my posting, say so below, and I will see if I need to mend my ways 🙂
0 Thanks
Reply
MistyV
Advocate

Re: Trouble with MS Remote desktop

Thanks Roy.

 

I am using Remote Desktop to connect to my work server, so I can access all the files saved on the server, from home.   If I was in the office, I would not use Remote Desktop.  

 

We used to just use remote desktop app - then we were hacked - and now we have both.  There is nothing I can do about this.  That said, when I've been testing everything, I've been doing it both - with VPN and without.

 

Is Port Forwarding still the answer?  The non-work IT engineer says no, but I'm embarrassed to say I can't get my head round it.  The link you sent (in nice simple non-tech terms) says it's required e.g. for a mail server, game server, access your computer remotely.

 

I'm accessing a work server / my work machine on the server remotely - is that the same thing?

 

Now TV community board says: 

  1. Choose the device the traffic should be forwarded to by selecting the appropriate radio button and take note of the IP it's assigned. Switching off devices you don't want to set up port forwarding on will reduce the list, making it easier to find devices by their device name.

>>Which is the device the traffic should be forwarded too?  My home laptop?  

 

Two different Now TV helpdesk people have said Port Forwarding it's the only option but they have also said that 'NowTV routers are not compatible with VPNs' because VPN is a 'work' thing - and they are consumer only.  

 

I know the work server  IP and port is 3389 but PortCheckTool.com says: 

Problem!  I could not see your service on <my IP> on port (3389).
Reason: Connection timed out.

 

The advice from a third Now TV person, and the non-work IT engineer, is get a new broadband provider.

 

Is that really my only option?

0 Thanks
Reply
RoyB Legend 5
Legend 5

Re: Trouble with MS Remote desktop

@MistyV 

 

I have to admit I’m a little confused 🤔

 

Lets go back to first principles.

 

In my job, there are just servers that I access at work. The company that I work for wouldn’t dream of letting any of us remote users on their network without coming in over a VPN, because of the hacking risk you suffered.

 

But if I had a desktop PC at work, which I normally used and kept files on, and I wanted to access that PC and compute on it, then I would use something like Remote Desktop on my laptop to access Remote Desktop on that PC, and I would expect my laptop to remain strictly a client, and for it to be the PC at work that needed the port forwarding, so it could act as a server for the requests my remote laptop made of it.

 

And you say you can get all this working from your laptop on another broadband provider, your local library I think it was, so it all seems to be setup OK at the work end, and even at your end, if you avoid the pesky NowTV Broadband, and/or its router.

 

Broadband services are pretty neutral overall. So I’m assuming that something in your router is blocking the Remote Desktop handshake between the copy on your desktop and the copy on your laptop, and that you have to Allow whatever it is through the router firewall.

 

The fix may be as simple as adding the IP address of your work PC to the Allowed websites list in Broadband Buddy, just as you had to do for the VPN, and additionally to that.

 

Use the internal IP address of the desktop PC, not any external address it may have, as this is what the router ‘sees’ over the VPN. IIUIC, the desktop must have a fixed IP address to work with Remote Desktop, and hopefully it is this internal IP address.

 

You probably know the IP address in question, but if not, then hopefully you can tracert the work desktop and get it.

 

So try that when you can, and let me know how you get on, and we can see if that fixes it, or if we have to think some more.

 

My working hypothesis is that NowTV Broadband is probably innocent here, but the router might not be; and as NowTV work very hard not to allow you to use a different router, you may indeed have to find a new broadband provider after all.

 

But we have a couple of things we can try first, starting with the above,

 

Crossed fingers.......

 

 


If my posting answered your question, please click ‘Accept Answer’
(As long as you started the thread, and haven’t already accepted an answer)
If you liked my posting, please click ‘Thanks’ (the thumbs-up icon)
If you disagree with my posting, say so below, and I will see if I need to mend my ways 🙂
0 Thanks
Reply
Highlighted
GaryL
Expert 2

Re: Trouble with MS Remote desktop

@MistyV  just a thought but have you tried turning off the firewall on your pc in case that is the problem, could be as simple as allowing the program through your firewall

0 Thanks
Reply
MistyV
Advocate

Re: Trouble with MS Remote desktop

Thanks Gary.

 

It's actually a mac and the firewall is actually already off.

0 Thanks
Reply
MistyV
Advocate

Re: Trouble with MS Remote desktop

Thanks again Rob.

 

When I occasionally work from home, I use my personal mac laptop.  My work machine, is a windows laptop.  This stays in the office.   This is because my work laptop is a heavy brick.  

 

At work, all my documents / files etc are saved on a server, not locally on my work laptop, so when I use remote desktop from home, I'm trying to access the work terminal server  - not my actual machine.  Is that right?  The variations of the server address are already in broadband buddy.

 

I understand that I can get my work laptop internal IP address but won't it will be xxx.xxx.xx.x right?  Broadband buddy doesn't accept that format - only text e.g. www.companygateway.com.

 

What am I missing?

 

THANK YOU!

 

 

0 Thanks
Reply
RoyB Legend 5
Legend 5

Re: Trouble with MS Remote desktop

Hi @MistyV 

 

Greetings from Roy.

 

I don’t have NowTV Broadband, and therefore no Broadband Buddy, so I don’t know what it looks like.

 

Did you have a web address for your office VPN? I don’t even know what ours is.

 

And as you are simply contacting a server, I don’t know why you would need Remote Desktop.

 

When my laptop is through to the VPN, I can browse the network at work, those areas I am allowed to access, and, as a convenience, I map the servers I want to access to unused drive letters on my laptop, after which I just access them as if they were drives directly on my laptop, albeit with the proviso that the mapping fails if the VPN isn’t set up first.

 

It may be that Remote Desktop is something to do with you using your own home laptop, which would be an utter non-no where I am.

 

Can you ask your IT guys to give you a potted description of what is actually going on? Where you are coming in to, what you can reach from there, what function Remote Desktop is performing, and so on?

 

And then we can perhaps make sense of it all.

 

 


If my posting answered your question, please click ‘Accept Answer’
(As long as you started the thread, and haven’t already accepted an answer)
If you liked my posting, please click ‘Thanks’ (the thumbs-up icon)
If you disagree with my posting, say so below, and I will see if I need to mend my ways 🙂
0 Thanks
Reply