cancel
Showing results for 
Search instead for 
Did you mean: 
Jayach
Elite

Pricing error on website?

Is there a pricing problem with the website. It says £21.00 for Super Fibre, but it charges £35.00 in the summary.

https://ibb.co/1fv9JGT

(Still can't embed images)

1 Solution
schnapps
Legend 5
Legend 5

Hi @Jayach 

 

I am guessing you have tried a different Internet browser and tried refreshing the screen page ?

View solution in original post

7 Replies
schnapps
Legend 5
Legend 5

Hi @Jayach 

 

Was you using a link from a comparison website ?

 

Somebody over on Twitter mentioned that Go Compare was giving the error price and when they tried another comparison website or using the NOW website direct the NOW Broadband prices was correct.

Jayach
Elite

Nope, direct to Now website, (although when I do join I will go via Quidco, they currently have a money back offer.)

Jayach
Elite

The reason I was checking is the comparison websites are no longer showing inclusive calls, which is important to me.

schnapps
Legend 5
Legend 5

Hi @Jayach 

 

Just had a quick look on the NOW website under Broadband Offers and couldn't see any mention of Anytime calls are now bundled with new customers orders.

 

Not even mentioned in the T&C's offer on their website, which was previously.

 

Perhaps drop NOW Broadband Team a message to see if they are still bundling Anytime Calls for free for the first year.

Jayach
Elite


@schnapps wrote:

Hi @Jayach 

 

Just had a quick look on the NOW website under Broadband Offers and couldn't see any mention of Anytime calls are now bundled with new customers orders.

 

Not even mentioned in the T&C's offer on their website, which was previously.

I couldn't find it on the website either, but the pricing shows +£8.00 then -£8.00 anytime offer (see above) so it seems to still be available, but it looks like things may be changing. and I've still got a couple of weeks on my Vodafone contract before I can leave.

schnapps
Legend 5
Legend 5

Hi @Jayach 

 

I am guessing you have tried a different Internet browser and tried refreshing the screen page ?

Jayach
Elite


@schnapps wrote:

Hi @Jayach 

 

I am guessing you have tried a different Internet browser and tried refreshing the screen page ?


I was using Edge, tried in Firefox and it was correct, tried again in Edge and now correct also, so don't know what it was. Panic over.